NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/46195: Unseen IDE CDROM drive on 6.0_BETA

The following reply was made to PR kern/46195; it has been noted by GNATS.

From: Aleksey Cheusov <>
To: Manuel Bouyer <>
Subject: Re: kern/46195: Unseen IDE CDROM drive on 6.0_BETA
Date: Fri, 16 Mar 2012 12:20:42 +0300

 On Thu, Mar 15, 2012 at 2:59 PM, Manuel Bouyer 
<> wro=
 > On Thu, Mar 15, 2012 at 08:50:05AM +0000, Aleksey Cheusov wrote:
 >> =A0I'm shocked. Changing CDROM drive to "master" has solved the problem.
 >> =A0Now it is recognized correctly. Could you please explain why it is no=
 >> =A0recommended
 > In T13/1532D Volume 1 Revision 2a "Information Technology - AT Attachment
 > with Packet Interface =AD 7 Volume 1 (ATA/ATAPI-7 V1) ", chapter 5.15.2
 > "Device 1 only configurations":
 > =A0 =A0 =A0 =A0Host support of Device 1 only configurations is host speci=
 > (T13/1532D is the one I have in hands to look at, older ATA standards sai=
 > that this was an unsupported configuration).
 > The consequence of this is that you can't reliably detect a slave
 > device if there's no master, unless you accept to pay a 31s timeout on
 > the nonexistent master in this case.
 Ok, thanks. If you think there is nothing to fix in NetBSD and
 appropriate specification
 is implemented completely and correctly feel free to close this PR.
 Let's call "local problem".
 Anyway, thanks for fixing this annoying problem!

Home | Main Index | Thread Index | Old Index