NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-i386/45704: kernel fails to boot on i486 CPU

The following reply was made to PR port-i386/45704; it has been noted by GNATS.

From: Jarle Greipsland <>
Subject: Re: port-i386/45704: kernel fails to boot on i486 CPU
Date: Fri, 17 Feb 2012 19:20:09 +0100 (CET)

 Jarle Greipsland <> writes:
 > some additional information.  This problem might actually be
 > unrelated to the floppy install stuff.  I dumped a MONOLITHIC
 > (5.99.56) kernel into the existing root file system on the
 > machine, updated the boot blocks, and rebooted.  I interrupted
 > the boot loader, got to the boot loaded prompt and redirected the
 > console to the serial port.  The log from the boot attempt
 > follows:
 > >> NetBSD/x86 BIOS Boot, Revision 5.9 (from NetBSD 5.99.56)
 > >> Memory: 639/65535 k
 > > boot netbsd -12s
 > 11522248+559748+449144 [579424+568209]=0xd0df20
 > Loading /stand/i386/5.99.56/modules/ffs/ffs.kmod  
 > and then the system spontanously rebooted.  The ffs.kmod file
 > does really exist at the path printed out above.  I have tried
 > with various combinations of the -1, -2 and -s flags to the
 > kernel, but the combination seems to make no difference.  Any
 > suggestions for what I should try next?
 More information.  I have performed a binary search and tried to
 find at which point this regression was introduced, and I believe
 that the merge of the rmind-uvmplock branch is to blame.  A
 kernel from the source tree based on the -current code at
  '2011-06-12 03:30:00 +00:00'
 boots just fine, while a kernel based on the same code at 
  '2011-06-12 03:40:00 +00:00'
 exhibits the behavior described in the problem report (i.e., it
 spontanously reboots immediately after loading).  The only commit
 within those 10 minutes is the rmind-uvmplock merge.
 Maybe no one has tested the new code on a genuine 486 processor
 until now?  It might be nice to have this fixed prior to the
 release of NetBSD 6, so that i486 processors will still be
 And just for the record, I tried to boot a -current MONOLITHIC
 kernel also, and it also spontanously reboots.
 "Not that this matters diddly poop in a 386/486/585.999998265 world."
                                -- Mike O'Brien

Home | Main Index | Thread Index | Old Index