NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-amd64/45652: cdplay doesn't work

>Number:         45652
>Category:       port-amd64
>Synopsis:       cdplay doesn't work
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    port-amd64-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Nov 25 14:05:00 +0000 2011
>Originator:     Don Allen
>Release:        5.1
dca@salome:~$ uname -a
NetBSD 5.1 NetBSD 5.1 (SALOME) #0: Tue Nov 22 12:38:17 EST 

First of all, yes, I am running a custom 5.1 kernel. But I've tested this with 
the GENERIC kernel and the problem remains.

dca@salome:/usr/pkgsrc/audio$ cd
dca@salome:~$ cdplay
Type `?' for command list

cdplay> play
cdplay: ioctl(CDIOCPLAYTRACKS): Invalid argument
cdplay> play 1
cdplay: ioctl(CDIOCPLAYTRACKS): Invalid argument

I *did* attempt to build the audio/cdplayer port, which initially failed. 
Sorry, I didn't save the session output. I then installed the cdplayer package, 
which succeeded, but CDPlayer did not work:

dca@salome:~$ CDPlayer
Shared object "" not found

I then tried building the audio/cdplayer port again and this time it succeeded 
(I'm guessing that the package dragged in dependency that failed to build from 
source previously). But CDPlay still doesn't work:

dca@salome:~$ CDPlayer
Undefined PLT symbol "FTC_Manager_New" (symnum = 396)

I'm telling you all this because I'm guessing that all of this unsuccessful 
mucking around with CDPlayer may have broken cdplay somehow.

See description.

Home | Main Index | Thread Index | Old Index