NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/45528: ral(4) unstable

>Number:         45528
>Category:       kern
>Synopsis:       ral(4) unstable
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Oct 28 03:05:00 +0000 2011
>Originator:     Thomas Klausner
>Release:        NetBSD 5.99.56

Architecture: x86_64
Machine: amd64
When using ral on NetBSD-current with the following hardware:
ral has not been converted to device_t
ral0 at pci2 dev 2 function 0: Ralink Technologies RT2561S 802.11b/g (rev. 0x00)
ral0: interrupting at ioapic1 pin 17
ral0: 802.11 address 00:1f:1f:59:57:52
ral0: MAC/BBP RT2561C, RF RT2527
ral0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ral0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps 24Mbps 
36Mbps 48Mbps 54Mbps

and wpa_supplicant on a wpa2 network, setting up the network connection works 
but after a short time using rtorrent with a few torrents, the network 
is lost.
When I then ping, I see:
ping: sendto: No buffer space available                                         

Same load & setup works fine with a wired network card, e.g.
re0 at pci7 dev 0 function 0: RealTek 8168/8111 PCIe Gigabit Ethernet (rev. 
re0: interrupting at ioapic0 pin 17
re0: Ethernet address 14:da:e9:20:0b:ce
re0: using 256 tx descriptors
rgephy0 at re0 phy 7: RTL8169S/8110S/8211 1000BASE-T media interface, rev. 2

Confiure ral0 as above on a WPA2 network, produce load, wait a few minutes.
Not provided.


Home | Main Index | Thread Index | Old Index