NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bin/44722

The following reply was made to PR bin/44722; it has been noted by GNATS.

From: Abhinav Upadhyay <>
Subject: Re: bin/44722
Date: Sat, 17 Sep 2011 23:47:26 +0530

 Not only ls(1) but probably a number of other programs are not behaving
 correclty under low file descriptor limit.
 For example:
 $ man ls
 .: 4: Invalid argument
 The error messages suggest that probably something is going wrong with
 the shell. Probably the shell tries to execute the shell built-in '.'
 (as observed by the above error message).
 It was even more weird to see that ls(1) and man(1) exited with proper
 error messages if I tried to do something like this:
 $ . ls #supply name of any executable file
 .: Cannot execute ELF binary /bin/ls
 $ ls
 ls: .: Too many open files
 $ man sh
 .: Can't open /etc/shrc
 So the bug probably is in the shell ?  The above worked with sh(1) , I
 also tried the same with bash(1) but it didn't work on bash.

Home | Main Index | Thread Index | Old Index