NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bin/43900 (ypbind(8) fails to handle multiple domains correcly)


now I've found the time to test it ...

I've took the "latest" version from MAIN (1.88).
It is working with two domains as it should do - at least if there are "ypservers" files present.

In my current setup I cannot check if fixing one domain by a servers-file and useing broadcast with another one is working correctly - sorry. "ypwhich -d dom2" runs in a timeout and I see some broadcast requests to rpcbind on the wire if I try to ask for a domain (dom2) without a servers-file in /var/yp/binding. But there is no answer, as it is, if I start ypbind with -broadcast for the default-domain.
I assume that it would work, if there someone will send an answer ....

I think you can close the report. Thanks.

PS: I do not need it in 5.x, because I have "my own" patch for it that makes it working for me.

Best reguards

W. Stukenbrock wrote:

Synopsis: ypbind(8) fails to handle multiple domains correcly

State-Changed-From-To: open->feedback
State-Changed-When: Tue, 24 May 2011 07:09:23 +0000
This should be fixed now in HEAD. Please give it a try in your environment;
I'm not set up to be able to test multiple domains.

On the minus side, releng is not going to want to pull all this rototill up
to netbsd-5. Do you need it fixed in netbsd-5, or are you ok with using
ypbind from -current until netbsd-6 comes out?

Home | Main Index | Thread Index | Old Index