NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-amd64/42895 (Weird ACPI messages every 30 seconds on the console)

On Wed 20 Apr 2011 at 05:56:38 +0000, wrote:
> Synopsis: Weird ACPI messages every 30 seconds on the console
> State-Changed-From-To: open->feedback
> State-Changed-By:
> State-Changed-When: Wed, 20 Apr 2011 05:56:37 +0000
> State-Changed-Why:
> I applied some fixes for these issues in 5.99.X -current. Can you see
> whether these made any difference? (Unfortunately, without the actual
> hardware, issues like this are extremely difficult to debug, leaving
> just some vague ideas on what might be wrong.)

I have to admit I just looked at the issue again a few days ago.

I used a recent -current (maybe about a week old now) and I re-adapted
my config file from GENERIC. This added 

acpicpu*        at cpu?         # ACPI CPU (including frequency scaling)

and this silences the messages!

(If this is because everything works now, or the failing attempt is not
tried any more, I don't know yet).

However, twice now the kernel with this option has frozen completely on
me, within minutes after boot and login.

I also noticed that estd (for dynamic frequency scaling) didn't like to
work any more. It claimed not to recognize the cpu. I had to re-add

options         ENHANCED_SPEEDSTEP

even though there also is

est0            at cpu0         # Intel Enhanced SpeedStep (non-ACPI)

This is probably unrelated, though.

___ Olaf 'Rhialto' Seibert  -- There's no point being grown-up if you 
\X/ rhialto/at/    -- can't be childish sometimes. -The 4th Doctor

Home | Main Index | Thread Index | Old Index