NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/44565: X works for about thirty seconds and then freezes on my MacBook1,1

   Date: Mon, 14 Feb 2011 15:20:19 +0100
   From: Martin Husemann <>

   On Mon, Feb 14, 2011 at 01:51:48PM +0000, Taylor R Campbell wrote:
   > (--) Using wscons driver on /dev/ttyE1 in pcvt compatibility mode (version 

   ttyE1 is likely the problem, check if you have a getty process running
   on ttyE1 (I suppose you have), I certainly do on most machines:

    375 ttyE1  Is+  0:00.08 /usr/libexec/getty ...

I have no getty processes running.  It may be worth mentioning that I
didn't install with sysinst (because other parts of sysinst are
broken, about which I suppose I ought to submit a PR), and I see that
sysinst on i386 tweaks /etc/ttys to enable ttyE[1-9].

   That process will fight with the X server for keyboard input. The X server
   is supposed to run on ttyE4 by default (X gets a "vt5" arg), I'm not sure
   what went wrong in your case.

Keyboard input isn't the problem.  If I have a terminal in focus when
the display freezes, I can still type into the terminal and observe
its effects.  (I typed `touch frobnozzle', and, sure enough, a file
called frobnozzle appeared in my home directory.)

I turned on ttyE[1-3] in /etc/ttys, shut down to single-user mode and
came back to multi-user mode, and tried running X again.  Xorg.log.0
says ttyE4, the mouse cursor is all wonky (it twitches all the time,
and if I touch the track pad to move it, it jumps to the bottom
right-hand corner of the screen before moving), and the display
freezes after thirty seconds or so again.

I rebooted the machine and tried running X again, which took ttyE4
again.  The mouse cursor is no longer all wonky, but the display still
freezes after thirty seconds.

Home | Main Index | Thread Index | Old Index