NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

lib/44549: apache1 crashes with segmentation fault cause of changes in libc between 2010-30-11 and 2011-05-02

>Number:         44549
>Category:       lib
>Synopsis:       apache1 crashes with segmentation fault cause of changes in 
>libc between 2010-30-11 and 2011-05-02
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    lib-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 11 09:40:00 +0000 2011
>Originator:     Stephan Pietzko
>Release:        netbsd-4
Uni Konstanz
Feb 10 13:03:02 CET 2011 
I am following the netbsd-4 branch on my server and have apache-1.3.42 
installed. I made the last update on 7. okt 2010 - everything works fine. 
Now i made an update on 5. Feb 2011 and after the reboot apache (same untouched 
binary) crashes with a segmentation error. I recompiled and installed the hole 
distribution and reinstalled apache-1.3.42 again and the error remains. The gdb 
of the httpd.core showed problems with libc.
 Than i took the src-tree from 2010-30.11, recompiled the hole distribution and 
the problem was gone.
Try netbsd-4 from 2011-05-02 and compile apache1 and try to start apache with 
the default-config. 

Home | Main Index | Thread Index | Old Index