NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-cobalt/44331: current hangs before/in init(8)

>Number:         44331
>Category:       port-cobalt
>Synopsis:       current hangs before/in init(8)
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    port-cobalt-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jan 05 23:00:01 +0000 2011
>Originator:     Martin Mersberger
>Release:        NetBSD-current (5.99.43)
NetBSD/cobalt current (5.99.43)
The system boots fine with 5.1 RELEASE, but it hangs when using current.
It looks a bit like port-cobalt/44292, but I do not get any message after pid 
1(init): ABI set to O32 (e_flags=0x1007)

here the full dmesg and backtrace, once it hangs (do not worry about wd0 in 
raidframe.. I've my 5.1 release install on that disk and have not added it to 
the raidframe mirror so far):

>> NetBSD/cobalt 5.1 Bootloader, Revision 0.9 [@0x80f00000]
>> (, Sat Nov  6 14:35:01 UTC 2010)
>> Model:               Cobalt RaQ
>> Memory:              131072 k
>> PROM boot string:    root=/dev/hda1 ro 
Boot [wd0a:netbsd]: wd1a:netbsd
Loading: wd1a:netbsd
3967184+113328 [228768+220979]=0x4525b0
Starting at 0x80001000

Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007, 2008, 2009, 2010, 2011
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 5.99.43 (GENERIC-PF) #0: Wed Jan  5 00:58:39 UTC 2011
Cobalt RaQ
total memory = 128 MB
avail memory = 120 MB
mainbus0 (root)
com0 at mainbus0 addr 0x1c800000 level 3: st16650a, working fifo
com0: console
cpu0 at mainbus0: QED RM5200 CPU (0x2810) Rev. 1.0 with built-in FPU Rev. 1.0
cpu0: 48 TLB entries, 16MB max page size
cpu0: 16KB/32B 2-way set-associative L1 Instruction cache
cpu0: 16KB/32B 2-way set-associative write-back L1 Data cache
mcclock0 at mainbus0 addr 0x10000070: mc146818 compatible time-of-day clock
panel0 at mainbus0 addr 0x1f000000
gt0 at mainbus0 addr 0x14000000
pci0 at gt0
pchb0 at pci0 dev 0 function 0: Galileo GT-64011 System Controller, rev 1
tlp0 at pci0 dev 7 function 0: DECchip 21143 Ethernet, pass 4.1
tlp0: interrupting at level 1
tlp0: Ethernet address 00:10:e0:00:06:e7
lxtphy0 at tlp0 phy 1: LXT970 10/100 media interface, rev. 0
lxtphy0: 10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
pcib0 at pci0 dev 9 function 0
pcib0: VIA Technologies VT82C586 PCI-ISA Bridge, rev 39
viaide0 at pci0 dev 9 function 1
viaide0: VIA Technologies VT82C586 (Apollo VP) ATA33 controller
viaide0: primary channel interrupting at irq 14
atabus0 at viaide0 channel 0
viaide0: secondary channel interrupting at irq 15
atabus1 at viaide0 channel 1
VIA Technologies VT83C572 USB Controller (USB serial bus, revision 0x02) at 
pci0 dev 9 function 2 not configured
wd0 at atabus0 drive 0: <WDC WD800JB-00ETA0>
wd0: 76319 MB, 155061 cyl, 16 head, 63 sec, 512 bytes/sect x 156301488 sectors
wd1 at atabus0 drive 1: <WDC WD800JB-00ETA0>
wd1: 76319 MB, 155061 cyl, 16 head, 63 sec, 512 bytes/sect x 156301488 sectors
raid0: RAID Level 1
raid0: Components: component0[**FAILED**] /dev/wd1a
raid0: Total Sectors: 156291072 (76314 MB)
boot device: raid0
root on raid0a dumps on raid0b
root file system type: ffs
pid 1(init): ABI set to O32 (e_flags=0x1007)

telnet> send break
Stopped in pid 0.2 (system) at  netbsd:cpu_Debugger+0x4:        jr      ra
                bdslot: nop
db> bt
cpu_Debugger+4 (ff00,0,79,6) ra 800426cc sz 0
comintr+508 (ff00,0,79,6) ra 800fa62c sz 64
cpu_intr+1d8 (ff00,0,79,6) ra 80167ea4 sz 64
mips3_KernIntr+84 (0,1c22a4d2,d60b6c8e,ca6c9ef0) ra 8016955c sz 128
cpu_idle+28 (0,1c22a4d2,d60b6c8e,ca6c9ef0) ra 8011b044 sz 24
idle_loop+104 (0,1c22a4d2,d60b6c8e,ca6c9ef0) ra 801684a8 sz 40
mips3_lwp_trampoline+18 (0,1c22a4d2,d60b6c8e,ca6c9ef0) ra 0 sz 24
User-level: pid 0.2

boot with current...

Home | Main Index | Thread Index | Old Index