NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/44212: Iyonix will not boot a kernel from IDE

>Number:         44212
>Category:       kern
>Synopsis:       Iyonix will not boot a kernel from IDE
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Dec 09 19:00:00 +0000 2010
>Originator:     Mike Howard
>Release:        NetBSD-current
NetBSD 5.99.41 (IYONIX51CC) #0: Mon Dec  6 22:40:22 GMT 2010
NetBSD has insttalled to a Maxtor 80GB drive. With the drive installed in the 
Iyonix and using boot32 to boot with the following commanf line 'boot32 netbsd 
root=/dev/wd0a' results in a failure of the machine to boot.

Everything works as expected upto and including leaving RiscOS. No  messages 
are displayed either on theconsole or serial port.

Attaching the drive to another (x86) NetBSD system reveals the logs have not 
been written to.

The iyonix is currently running RiscOS 5.16 and NetBSD was not tried with any 
earlier OS versions on this machine.

Refit drive to the machine, on either IDE interface, in any Master/Slave order 
results in no boot.
Not really a fix but, attach the drive to an IDE->USR coverter ('Easy IDE') and 
the system will boot using 'boot32 netbsd root=/dev/sd0a'.

Maybe the _fairly_ recent RiscOS 5.16 rom update has caused the issue?

Home | Main Index | Thread Index | Old Index