NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-i386/44092: Cannot copy (/bin/cp) to smbfs-mounted partition

Hello David,

I played with file size, and found that both commands cp/cat work while size is <= 136 bytes. That's interesting :)


On 11/15/10 22:05, David Holland wrote:
The following reply was made to PR port-i386/44092; it has been noted by GNATS.

From: David Holland<>
Subject: Re: port-i386/44092: Cannot copy (/bin/cp)  to smbfs-mounted
Date: Mon, 15 Nov 2010 21:01:32 +0000

  On Mon, Nov 15, 2010 at 09:55:00AM +0000, wrote:
   >  After mount_smbfs remote filesystem it is not possible to copy file
   >  to it: I can read the FS, can create zero-length files on it, can
   >  edit and save files on it but can not copy file to it. With NetBSD
   >  4.0.1 it worked...
   >  $ sudo cp mine.xls /mnt/u/S/Upgrade_2006/
   >  cp: /mnt/u/S/Upgrade_2006/mine.xls: No buffer space available
   >  $
   >  [...]
   >  Nov 15 10:49:24 dinah /netbsd: WARNING: mclpool limit reached;
   >  increase NMBCLUSTERS
   >  ALso I tried to increase 'NMBCLUSTERS' 10x in kernel, recompile it
   >  but it did'n help: I got the old same "mclpool limit reached"

  Is mine.xls large? (Does this happen even with small files?) Does "cat
  mine.xls>  /mnt/u/S/Upgrade_2006/mine.xls" also fail?

  My understanding is that smbfs is considered experimental in the
  netbsd-5 branch and can't really be expected to work, but I thought it
  worked a little better than this.

  If the answer is that mine.xls is large, small files work ok, and cat
  also works, then this is moderately likely to make the problem go

     cd /usr/src/bin/cp
     cvs update -j1.34 -j1.36 utils.c
     make obj
     make dependall install

  If this is the case please let us know.

  David A. Holland

Home | Main Index | Thread Index | Old Index