NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re : Re : kern/43806: No sound on Thinkpad T510

Mmm,  I just realized pidgin does play sound :|
When launching from the console, it displays the message

GConf Error: Failed to contact configuration server; some possible causes are 
that you need to enable TCP/IP networking for ORBit, or you have stale NFS 
due to a system crash. See for information. 
(Details -  1: Failed to get connection to session: Failed to execute 
dbus-launch to autolaunch D-Bus session)

Everytime I preview a sound, so I guess that's one thing I can start tracking 
down :)


----- Message d'origine ----
De : le chapelain germain <>
À :;;;
Envoyé le : Jeu 11 novembre 2010, 23h 00min 01s
Objet : Re : kern/43806: No sound on Thinkpad T510


I am doing more poking at this right now.

I have tried upgrading to current (you never know..)  

then going

bash-4.1# ln -fs  /dev/audio4 /dev/audio
bash-4.1# ls -lrt /dev/audio
lrwxr-xr-x  1 root  wheel  11 Nov 11 15:39 /dev/audio -> /dev/audio4

(since I get 
hdafg4 at hdaudio1: Conexant CX20585
hdafg4: DAC00 2ch: HP Out [Jack]
hdafg4: ADC01 2ch: Mic In [Jack]
hdafg4: DAC02 2ch: Speaker [Built-In]
hdafg4: ADC03 2ch: Mic In [Built-In]
hdafg4: 2ch/2ch 44100Hz 48000Hz 96000Hz 16/16 20/32 24/32
audio4 at hdafg4: full duplex, playback, capture, independent)

I still got no sound coming out of mplayer in root or user, without any 
particular error message.

mixerctl -a returns

bash-4.1# mixerctl -a

I have tried going

bash-4.1# mixerctl -w outputs.dacsel=DAC02
mixerctl: Bad set value DAC02

I don't mind investigating more but as you can tell I have no idea what I am 
All I know is I have heard sound coming out of my computer once on netbsd 5

Please, help me !..

Germain Le Chapelain
( Sorry for the poor formatting of the previous message. )

----- Message d'origine ----
De : le chapelain germain <>
À :;;;
Envoyé le : Mer 13 octobre 2010, 8h 20min 04s
Objet : Re: kern/43806: No sound on Thinkpad T510

The following reply was made to PR kern/43806; it has been noted by GNATS.

From: le chapelain germain <>
Subject: Re: kern/43806: No sound on Thinkpad T510
Date: Wed, 13 Oct 2010 07:26:39 +0100 (BST)

Hi,=0A=0A=0AI can hear and tune the sound when I launch mplayer as a root.=
=0A=0AI tried playing with the permission of /dev/audio*, and then I was no=
t even able to play a movie any longer.  When I would quit mplayer, I could=
  not enter anything in the terminal.=0A=0APressing enter would echo the pro=
mpt "bash-4.1$" without a carriage return.=0A=0Aafter changing /dev/audio, =
mixer and mixerctl to 777 i was able to play a movie again both as a user a=
nd as root, but still no sound as a user.=0A=0AWhat could cause this ?=0A=
=0AMy permissions now looks like this :=0A=0Acrwxrwxrwx  1 root  wheel  42,=
   16 Aug 20 09:36 mixer0=0Acrwxrwxrwx  1 root  wheel  42, 192 Aug 20 09:36 =
audioctl0=0Acrw-rw-rw-  1 root  wheel  42, 129 Aug 20 09:36 audio1=0Acrw-rw=
-rw-  1 root  wheel  42,  17 Aug 20 09:36 mixer1=0Acrw-rw-rw-  1 root  whee=
l  42, 193 Aug 20 09:36 audioctl1=0Acrw-rw-rw-  1 root  wheel  42, 130 Aug =
20 09:36 audio2=0Acrw-rw-rw-  1 root  wheel  42,  18 Aug 20 09:36 mixer2=0A=
crw-rw-rw-  1 root  wheel  42, 194 Aug 20 09:36 audioctl2=0Acrw-rw-rw-  1 r=
oot  wheel  42, 131 Aug 20 09:36 audio3=0Acrw-rw-rw-  1 root  wheel  42,  1=
9 Aug 20 09:36 mixer3=0Acrw-rw-rw-  1 root  wheel  42, 195 Aug 20 09:36 aud=
ioctl3=0Alrwxrwxrwx  1 root  wheel        6 Aug 20 09:36 audio -> audio0=0A=
lrwxrwxrwx  1 root  wheel        6 Aug 20 09:36 mixer -> mixer0=0Alrwxrwxrw=
x  1 root  wheel        9 Aug 20 09:36 audioctl -> audioctl0=0Acrw-rw-rw-  =
1 root  wheel  42,  20 Sep  1 04:12 mixer4=0Acrw-rw-rw-  1 root  wheel  42,=
  196 Sep  1 04:12 audioctl4=0Acrw-rw-rw-  1 root  wheel  42, 132 Oct 12 22:=
18 audio4=0Acrwxrwxrwx  1 root  wheel  42, 128 Oct 12 23:16 audio0=0A=0ATha=
nks !=0A=0A=0AGermain=0A=0A--- En date de=A0: Dim 29.8.10, bch@methodlogic.=
net <> a =E9crit=A0:=0A=0A> De: <bch=>=0A> Objet: Re: kern/43806: No sound on Thinkpad T510=0A> =
=C0:> Cc:, gnats-admin@=,,> Date: Dimanch=
e 29 ao=FBt 2010, 23h35=0A> On Sun, Aug 29, 2010 at 06:40:04PM=0A> +0000, M=
anuel Bouyer wrote:=0A> > The following reply was made to PR kern/43806; it=
  has=0A> been noted by GNATS.=0A> > =0A> > From: Manuel Bouyer <bouyer@anti=>=0A> > To:> > Cc: 
kern-bug-people@NetB=,=0A>,=0A>,=0A> >=A0 =
=A0 =A0> > Subject: Re: kern/43806: 
No so=
und on Thinkpad T510=0A> > Date: Sun, 29 Aug 2010 20:39:10 +0200=0A> > =0A>=
  >=A0 On Sun, Aug 29, 2010 at 06:30:06PM +0000,> wro=
te:=0A> >=A0 >=A0 On my system (NetBSD kamloops 5.99.39=0A> NetBSD 5.99.39 =
(kamloops) #205: Thu Aug 26 19:35:29 PDT=0A> 2010=A0=0A> root@kamloops:/usr=
/obj/sys/arch/amd64/compile/kamloops=0A> amd64), I've got:=0A> >=A0 >=A0 =
=0A> >=A0 >=A0 kamloops# ls -ld /dev/hdau*=0A> >=A0 >=A0 crw-r--r--=A0 1 ro=
ot=A0=0A> wheel=A0 195, 0 Apr 20 19:57 /dev/hdaudio0=0A> >=A0 >=A0 crw-r--r=
--=A0 1 root=A0=0A> wheel=A0 195, 1 Apr 20 19:57 /dev/hdaudio1=0A> >=A0 >=
=A0 crw-r--r--=A0 1 root=A0=0A> wheel=A0 195, 2 Apr 20 19:57 /dev/hdaudio2=
=0A> >=A0 >=A0 crw-r--r--=A0 1 root=A0=0A> wheel=A0 195, 3 Apr 20 19:57 /de=
v/hdaudio3=0A> >=A0 >=A0 =0A> >=A0 >=A0 =0A> >=A0 >=A0 ....but I just delet=
ed them, and=0A> playing (via xmms) seems to work,=0A> >=A0 >=A0 but hdaudi=
octl now does not...=0A> >=A0 >=A0 =0A> >=A0 >=A0 I'll test on next reboot =
if my audio=0A> needs to have it's seemingly typical=0A> >=A0 >=A0 "hdaudio=
ctl set 0x00 0x01" to get=0A> audible output.=0A> =0A> I just rebooted and =
indeed, xmms throws no errors and shows=0A> signs of=0A> working (i.e. audi=
o meters are working, timer is counting),=0A> but no=0A> audio is emitted f=
rom built-in speakers. I reinstalled the=0A> hdaudio0=0A> device, performed=
  an "hdaudioctl get 0x00 > hd_before"=0A> to capture it's=0A> current setti=
ngs, "hdaudioctl set 0x00 0x01" to "jostle"=0A> the audio, then=0A> "hdaudi=
octl get 0x00 0x01 > hd_after". The speakers are=0A> now making sounds,=0A>=
  but a "diff -bu on hd_before hd_after" yields no=0A> differences.=0A> =0A>=
  -bch=0A> =0A> >=A0 I was not aware we had a /dev/hdaudio*=0A> >=A0 so=0A> =
>=A0 cd /dev/ && ./MAKEDEV hdaudio0 hdaudio1=0A> hdaudio2 hdaudio3=0A> >=A0=
  should create them if missing.=0A> >=A0 =0A> >=A0 -- =0A> >=A0 Manuel Bouy=
er <>=0A> >=A0 =A0 =A0=A0=A0NetBSD: 26 ans=0A> 
rience feront toujours la difference=0A> >=A0 --=0A> >=A0 =0A> =0A> -- =0A>=
  Brad Harder=0A> Method Logic Digital Consulting=0A>
=0A>> =0A> =0A=0A=0A      

Home | Main Index | Thread Index | Old Index