NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-amd64/43833: SVR$ compat support missing for amd64

The following reply was made to PR port-amd64/43833; it has been noted by GNATS.

From: (Christos Zoulas)
Subject: Re: port-amd64/43833: SVR$ compat support missing for amd64
Date: Sat, 4 Sep 2010 06:48:23 -0400

 On Sep 3, 11:45am, 
( wrote:
 -- Subject: port-amd64/43833: SVR$ compat support missing for amd64
 | >Number:         43833
 | >Category:       port-amd64
 | >Synopsis:       SVR$ compat support missing for amd64
 | >Confidential:   no
 | >Severity:       non-critical
 | >Priority:       medium
 | >Responsible:    port-amd64-maintainer
 | >State:          open
 | >Class:          change-request
 | >Submitter-Id:   net
 | >Arrival-Date:   Fri Sep 03 11:45:01 +0000 2010
 | >Originator:     W. Stukenbrock
 | >Release:        NetBSD 5.0.2
 | >Organization:
 | Dr. Nagler & Company GmbH
 | >Environment:
 | System: NetBSD s051 5.0.2 NetBSD 5.0.2 (NSW-S051) #2: Thu Aug 12 18:30:48 
CEST 2010 wgstuken@s051:/usr/src/sys/arch/amd64/compile/NSW-S051 amd64
 | Architecture: x86_64
 | Machine: amd64
 | >Description:
 |      There is still no SVR4 compat support for this architecture.
 |      It would be very niche to have that in order to run Solaris X86 
binaries on a NetBSD system.
 |      My concrete problem is, that the JRE for linux (64 and 32) bit will not 
work reliable in the
 |      linux or linux32 emulations. There seems to be a timing problem during 
startup of the engine,
 |      so that it will crash most times. If the machine-code-compiler is 
deactivated on the command line
 |      for the java program, the JRE comes up most times - still not all the 
 |      I simply hope that JRE would run much more stable on Solaris as it does 
on any Linux and that
 |      it would work in the emulation too.
 |      At the moment it is impossible to run a JRE on a NetBSD-5.0.2-amd64 
system in a reliable way.
 |      A quick-try from my side by just enabling the SVR4 compat in an amd64 
kernel shows, that
 |      (at least) some lines in files.amd64 are missing (see below) and that 
the machine dependen headerfiles
 |      svr4_machdep.h and svr4_32_machdep.h must be written.
 |      "missing" lines in files.amd64:
 | # SVR4 binary compatibility (COMPAT_SVR4)
 | include "compat/svr4/files.svr4"  
 | # file    arch/i386/i386/svr4_machdep.c           compat_svr4
 | # file    arch/i386/i386/svr4_sigcode.S           compat_svr4
 | # file    arch/i386/i386/svr4_syscall.c           compat_svr4
 | # SVR4 binary compatibility (COMPAT_SVR4_32)
 | include "compat/svr4_32/files.svr4_32"  
 | # file    arch/i386/i386/svr4_machdep.c           compat_svr4_32
 | # file    arch/i386/i386/svr4_sigcode.S           compat_svr4_32
 | # file    arch/i386/i386/svr4_syscall.c           compat_svr4_32
 |      END of missing lines
 |      Accedently my knowledge about the stack-frame differences of 32 and 64 
bit Intel-CPU's is nearly zero.
 |      So I cannot guess a valid svr4_*machdep.h file and try if the rest of 
the emulation is already working.
 Is there a place to download solaris binaries so we can test?
 Also the linux emulation works much better in NetBSD/current and also you
 can build native java binaries using the OpenJDK.

Home | Main Index | Thread Index | Old Index