NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-i386/43331: X server locks up under -current on NEC Versa DayLite laptop

>Number:         43331
>Category:       port-i386
>Synopsis:       X server locks up under -current on NEC Versa DayLite laptop
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-i386-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu May 20 14:40:01 +0000 2010
>Originator:     Andreas Gustafsson
>Release:        NetBSD-current source date 2010.
System: NetBSD
Architecture: i386
Machine: i386

I have a NEC Versa DayLite laptop which has been happily running
NetBSD 4.99.30 for a couple of years.  When I tried upgrading to a
-current kernel, it booted successfully (modulo PR 42058), but when I
started the X server using "startx", it took a long time to start up
(40 seconds instead of the usual 5) and when it finally started, the
mouse cursor did not respond to the touchpad.  The machine was still
up, as I could still log in to it over the network.

This might be related to the following error reported by pckbc in 

  pckbc1 at acpi0 (USKB, PNP0303) (kbd port): io 0x60,0x64 irq 1
  [...many lines pertaining to other ACPI devices omitted...]
  pckbd0 at pckbc1 (kbd slot)
  pckbc1: using irq 1 for kbd slot
  wskbd0 at pckbd0: console keyboard
  pms0 at pckbc1 (aux slot)
  pckbc1: unable to establish interrupt for aux slot

This behavior and the pckbc error look similar to those reported on
amd64 in PR 35435.  Figuring the problem might be ACPI related, I
tried building a custom kernel with

  no pckbc*               at acpi?

With that kernel, X starts normally, and I'm using it to write this
bug report.


Good luck finding a NEC Versa DayLite these days :)


Don't know how, but at least there is a work-around.

Home | Main Index | Thread Index | Old Index