NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/43063: Please delete __NetBSD_Prereq__() from <sys/param.h>

The following reply was made to PR kern/43063; it has been noted by GNATS.

From: David Holland <>
Subject: Re: kern/43063: Please delete __NetBSD_Prereq__() from
Date: Sat, 27 Mar 2010 19:31:11 +0000

 On Fri, Mar 26, 2010 at 02:10:06PM +0000, Martin Husemann wrote:
  >  We could instead provide both variants as
  >    __NetBSD_older_than__(maj,min) /* NetBSD older than maj.min */
  >  and
  >    __NetBSD_newer_than__(maj,min) /* NetBSD maj.min or newer */
  >  if there realy is a need for such a test in pkgsrc world. Pkgsrc folks?
 In general I don't think there is. But we ought to provide these
 anyway because the alternative is inspecting the bit representation of
 __NetBSD_Version__ and it'd be just as well to avoid/discourage that.
 David A. Holland

Home | Main Index | Thread Index | Old Index