NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/42485: ral(4): RT2561S does not connect

>Number:         42485
>Category:       kern
>Synopsis:       ral(4): RT2561S does not connect
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Dec 20 16:30:00 +0000 2009
>Originator:     Thomas Klausner
>Release:        NetBSD 5.99.22
Curiosity is the very basis of education and if you tell me that
curiosity killed the cat, I say only that the cat died nobly.
- Arnold Edinborough
System: NetBSD 5.99.22 NetBSD 5.99.22 (YT) #30: Sun Dec 20 13:09:04 
CET 2009 amd64
Architecture: x86_64
Machine: amd64
ral0 at pci2 dev 2 function 0: Ralink Technologies RT2561S 802.11b/g (rev. 0x00)
ral0: interrupting at ioapic1 pin 17
ral0: 802.11 address xx:xx:xx:xx:xx:xx
ral0: MAC/BBP RT2561C, RF RT2527
ral0: 11b rates: 1Mbps 2Mbps 5.5Mbps 11Mbps
ral0: 11g rates: 1Mbps 2Mbps 5.5Mbps 11Mbps 6Mbps 9Mbps 12Mbps 18Mbps
24Mbps 36Mbps 48Mbps 54Mbps

I could configure the network, it automatically found the correct SSID
and channel. The "TX rate (actual speed)" in wiconfig dropped and
dropped until it was at "1"; I couldn't ping the access point:
PING ap ( 56 data bytes
ping: sendto: Host is down

Roy Marples (roy@) sees the same problem and wrote:
FWIW, Linux had the same issue with the driver RALink produced and the
open source variant of that. It wasn't until they re-wrote the whole
driver against the new wireless stack that it actually worked with any
great reliability.

Matthew Sporleder ( wrote:
My ral (old belkin usb- worked at some point with ural driver) gives::

ral0: could not open Tx pipe: IN_USE
ral0: cannot assign link-local address

And then it sort of acts like it works but it doesn't.
See above.


Home | Main Index | Thread Index | Old Index