NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/42371: No phy on 82801I wm(4) and thus no media

>Number:         42371
>Category:       kern
>Synopsis:       82801I wm(4) does not attach a phy, so no media detected
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Nov 24 12:25:00 +0000 2009
>Originator:     Stephen Borrill
>Release:        NetBSD 5.0_STABLE
System: NetBSD laptop 5.0_STABLE NetBSD 5.0_STABLE (GENERIC) #8: Sun Oct 18 
21:05:39 BST 2009 root@laptop:/usr/obj/5.0/amd64/sys/arch/amd64/compile/GENERIC 
Architecture: x86_64
Machine: amd64
On a Lenovo ThinkPad T500:
# dmesg | grep wm0
wm0 at pci0 dev 25 function 0: 82801I mobile LAN Controller, rev. 3
wm0: interrupting at ioapic0 pin 20
wm0: PCI-Express bus
wm0: FLASH
wm0: Ethernet address 00:22:68:10:12:fb
# ifconfig -m wm0
        address: 00:22:68:10:12:fb
        media: Ethernet none (none)
        supported Ethernet media:
                media none
        inet netmask 0xffffff00 broadcast
        inet6 fe80::222:68ff:fe10:12fb%wm0 prefixlen 64 scopeid 0x1

Note there is no xxphy0 at wm0 line and no media is detected.

The interface works fine, but programs like dhcpcd which use carrier detect

Problem exists on -current too:
NetBSD laptop 5.99.22 NetBSD 5.99.22 (GENERIC) #2: Tue Nov 24 12:13:07 GMT 2009 
 root@laptop:/usr/obj/current/amd64/sys/arch/amd64/compile/GENERIC amd64

Buy a T500. I understand the problem affects other recent
ThinkPads too


Home | Main Index | Thread Index | Old Index