NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/42175: smbfs doesn't support files large than 4GB

>Number:         42175
>Category:       kern
>Synopsis:       smbfs doesn't support files large than 4GB
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Oct 12 11:05:00 +0000 2009
>Release:        NetBSD 5.99.20
Matthias Scheler                        
System: NetBSD 5.99.20 NetBSD 5.99.20 (LYSSA) #0: Mon Oct 
12 09:54:46 BST 2009 
Architecture: i386
Machine: i386
To test NetBSD-current's SMBFS I tried to write a large file to my
Apple Time Capsule. It worked fine until the file got larger
than 4GB:

tron@lyssa:/mnt#dd if=/dev/zero bs=1024k count=5120 of=test.img
dd: test.img: File too large
4097+0 records in
4096+0 records out
4294967296 bytes transferred in 367.010 secs (11702589 bytes/sec)

I don't think this is a problem with the Time Capsule (which is *not*
using Samba) as I can upload and download files larger than 10GB
with Samba's "smbclient" without problems.

mount -t smbfs ... /mnt
dd if=/dev/zero bs=1024k count=5120 of=test.img

Not known.

Home | Main Index | Thread Index | Old Index