NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bin/41029: srtconfig is located on /usr filesystem but needed during startup when /usr is not mounted

>Number:         41029
>Category:       bin
>Synopsis:       srtconfig is located on /usr filesystem but needed during 
>startup when /usr is not mounted
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Mar 17 08:25:00 +0000 2009
>Originator:     Dr. Wolfgang Stukenbrock
>Release:        NetBSD 5.0_RC
Dr. Nagler & Company GmbH
System: NetBSD s012 4.0 NetBSD 4.0 (NSW-S012) #9: Fri Mar 13 12:31:52 CET 2009 
wgstuken@s012:/usr/src/sys/arch/amd64/compile/NSW-S012 amd64
Architecture: x86_64
Machine: amd64
        In order to setup an srt interface the config utility program 
srtconfig(1) is needed.
        But this program is located in /usr/sbin and /usr is still not mounted 
when the interface configuration is setup by the rc-scripts.
        So it is impossible to initialize srt interfaces during startup due to 
the not available configuration utility program.
        setup an<x> and try to configure it during boot - the /usr 
is still not mounted and the setup will fail. /usr/sbin7srtconfig is not 
        move the srtconfig utility program from /usr/sbin to /sbin.
        All other config utilities (link e.g. pppoectl) are located in /sbin 


Home | Main Index | Thread Index | Old Index