NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/40561: Fixed in 4.99.72 arised in NetBSD 5 RC1 --- AHCISATA does not support WD2500 SATA disk


Sorry for late reply. I was away from that machine.

Disabling ACPI does not chnage anything, but disabling ACPI and SMP works, it booted 6 times without problem. Just a reminder: Installation CD of 4.99.72 works without problem with or without SMP, ACPI.


Manuel Bouyer, 02/07/09 00:30:
On Fri, Feb 06, 2009 at 01:03:47AM +0200, Cem Kayali wrote:

I couldn't reproduce the issue using installed NetBSD-RC1, but re-produced using NetBSD5-RC installation CD. Maybe installation CD was in CDROM and it booted from CD instead of disk. So, i update the problem such that problem is within NetBSD5-RC1 installation CD - not installed NetBSD5-RC1 one.

To make sure i compared installation CDs of 4.99.72 and NetBSD5-RC1.

NetBSD5-RC1 installation CD: It does not freeze but i never see installation screen occasionally, ratio about 1/3 boot - tried about 10 times NetBSD 4.99.72 installation CD: It always succesfully boots - tried about 10 times

Here are photos taken:


The fact that both piixide and ahcisata have interrupt issues makes
me think interrupts are not working properly on this setup. I guess
it's more general than just ahcisata.

PS: Does not installation CD install same/similar kernel?

Both should use GENERIC, I think. Can you confirm the kernel booted from
your CD is GENERIC ? Did you use boot option to disable acpi or SMP in
some of your tries ?

Home | Main Index | Thread Index | Old Index