NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: port-atari/40315: Bootloader fails on Atarit TT030

Ok, I just tried an install onto a 512MB partition. (After that there's 128MB of swap, then nothing else.) I get the same result -- the bootloader (presumably the first stage) just prints "Halting..." to the console and dies.


The bootstrap is split into three parts: a small first-stage program that
    resides in the (physically) first 512 bytes on the device (as specified
    by Atari Corp.), a second-stage program that immediately follows the
    first-stage program, and a third-stage program that resides on the root

I know the second stage bootloader prints a banner, but I'm not seeing it before the crash. So it does seem that at this early stage in the boot process, we're dealing with locations only very close to the beginning of the disk. In any case, my new install onto a 512MB partition demonstrates that this bug is not caused by a 2GB firmware limit.

David Ross

----- Original Message ----- From: "Izumi Tsutsui" <> To: <>; <>; <>; <>
Sent: Saturday, January 03, 2009 12:15 PM
Subject: Re: port-atari/40315: Bootloader fails on Atarit TT030

The following reply was made to PR port-atari/40315; it has been noted by GNATS.

From: Izumi Tsutsui <>
Subject: Re: port-atari/40315: Bootloader fails on Atarit TT030
Date: Sun, 4 Jan 2009 05:11:47 +0900

> It's not the firmware -- previously I had been running NetBSD 1.6.1 rock
> solid for months, with heavy disk activity. During that time I never > had
> any boot issues or any issues that would indicate there's a 2GB limit.

We have to confirm each possible problem in such case.

"1.6.1 worked" doesn't mean firmware can read sectors beyond >2GB range.
If bootstrap files were stored in <2GB range in >2GB disk,
it just worked even if there was 2GB limit, and
IIRC the default partition sizes created by sysinst
were quite different between 1.6 and 4.0.

Of course NetBSD kernel supports >2GB access (we have own drivers)
so once it booted properly it should work solid ~forever.

If current bootloder doesn't work even with <2GB root partition,
it could be an evidence which indicates other problems.

> If it would help, I can upload a disk image of a working 1.6.1 install, > same > format as the HEAD disk image already included in this PR. Then looking > at
> the differences between the two should help pinpoint the problem.

I can't bunzip2 your HEAD image, as I wrote in the previous message.
Could you confirm it's valid?
Izumi Tsutsui

Home | Main Index | Thread Index | Old Index