NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: kern/39211: ubsa device does no longer work since January 2008

The following reply was made to PR kern/39211; it has been noted by GNATS.

From: Matthias Drochner <>
To: Frank Wille <>
Subject: Re: kern/39211: ubsa device does no longer work since January 2008 
Date: Thu, 31 Jul 2008 22:31:19 +0200 said:
 > But I'm anxious that uhmodem needs ubsa to be at usbifif
 If it does, it is incorrect, and needs to be fixed. ubsa
 was there earlier, and there is no excuse for breaking it.
 I'm not going to break uhmodem intentionally, and we should
 try to solicit testers, but the ubsa attachment change is
 obviously wrong and it is pure luck that it doesn't lead
 to crashes.
 So did you test with UBSA_DEFAULT_CONFIG_INDEX set to 0 or 1?
 > 1. 12x "ubsa0: ubsa_request: STALLED" when connecting to ucom0.
 That would need some more extensive debugging to find out -- might
 be misbehaviour of the device or a host adapter driver bug.
 (I don't really believe in the latter, but I can't rule it out.)
 > detaches and attaches again
 That's likely device misbehaviour - it drops out in some way.
 This might be worked around by adding some timeouts in the
 attach/detach detection code.
 But this is dangerous because if someone manages to eg switch
 a USB memory stick for another one so that the switch gets
 not detected, serious data corruption could happen.
 (Of course one should't switch a mounted memory stick, but anyway.)
 best regards
 Forschungszentrum Juelich GmbH
 52425 Juelich
 Sitz der Gesellschaft: Juelich
 Eingetragen im Handelsregister des Amtsgerichts Dueren Nr. HR B 3498
 Vorsitzende des Aufsichtsrats: MinDir'in Baerbel Brumme-Bothe
 Geschaeftsfuehrung: Prof. Dr. Achim Bachem (Vorsitzender),
 Dr. Ulrich Krafft (stellv. Vorsitzender), Prof. Dr. Harald Bolt,
 Dr. Sebastian M. Schmidt

Home | Main Index | Thread Index | Old Index