NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

misc/39160: git installs incorrectly, configure passes but gmake fails to find /usr/bin/perl

>Number:         39160
>Category:       misc
>Synopsis:       git installs incorrectly, configure passes but gmake 
>fails to find /usr/bin/perl
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    misc-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Jul 17 13:50:00 +0000 2008
>Originator:     Tom Burns
>Release:        NetBSD 2.1.0_STABLE
NetBSD sdf 2.1.0_STABLE NetBSD 2.1.0_STABLE (sdf) #0: Fri Mar 30 02:24:32 UTC 
2007  root@ol:/var/sys/arch/alpha/compile/sdf alpha
installed git is missing the binary "git-unpack-objects" which results 
in pushing to this server from a remote host fails.

While manually installing git I noticed that I get the same result (missing 
binaries) if I do not specify --with-perl=`which perl` on the ./configure step. 
 Configure will pass anyways but the make will end prematurely.

Installing git 1.5.6 DOES NOT fix the problem, in fact it looks worse? only 
binaries available are git and gitk.. and while "git unpack-objects" works 
git-unpack-objects is missing so remote pushes still fail.  Unless I can 
configure my host to use the built-in git command.
install git from pkgsrc.  See that "git-unpack-objects" does not exist

Home | Main Index | Thread Index | Old Index