NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-i386/39070: No sound out of ASUS Eee PC 900

>Number:         39070
>Category:       port-i386
>Synopsis:       Sound is not working on ASUS Eee PC 900
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-i386-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Jun 30 22:00:00 +0000 2008
>Originator:     ptiJo
>Release:        NetBSD 4.99.64
System: NetBSD 4.99.64 NetBSD 4.99.64 (GENERIC) #1: Mon Jun 30 
00:51:16 CEST 2008 
Architecture: i386
Machine: i386
        I have installed 4.99.64/i386 on my ASUS Eee PC 900 and I can't get any 
sound out of it.
        The same release works OK on my ASUS Eee PC 701. I checked with a more 
recent GENERIC (4.99.66) and it fails the same way.
        What I have noticed is a strange line in dmesg:
azalia0 at pci0 dev 27 function 0: Generic High Definition Audio Controller
azalia0: interrupting at ioapic0 pin 16
azalia0: host: 0x8086/0x2668 (rev. 4), HDA rev. 1.0
wd0 at atabus1 drive 0azalia0: codec[0]: Realtek ALC662-GR (rev. 1.1), HDA rev. 
audio0 at azalia0: full duplex, independent
        This wd0/azalia0 line is not there on the Eee PC 701.
        On the Eee PC 701, NetBSD reports wd0 is "<SILICONMOTION SM223AC>" and 
azalia0 is "Realtek ALC662-GR (rev. 1.1), HDA rev. 1.0" ; sound works.
        On the Eee PC 900, NetBSD reports wd0 is "<ASUS-PHISON OB SSD>" and 
azalia0 is "Realtek ALC662-GR (rev. 1.1), HDA rev. 1.0".
        Comparing the 701 and 900 with Unbuntu Linux, I found that the 701 
audio card has "Subsystem Id: 0x104382a1" when it is "Subsystem Id: 0x10438337" 
on the 900. I have no idea though if this is the issue.
        I tested with Windows XP, Ubuntu 8.04 : sound is OK.

        I tried booting OpenBSD 4.3-current on both (701 & 900).
        On the 701, it boots fine.
        On the 900, the boot stops just before what is the wd0 description line 
on the 701. I never see the "wd0 at atabus..." on the 900.

        I tried NetBSD GENERIC and GENERIC + ath0 patches.
        I tried to switch on/off value using NetBSD mixerctl.
        I tried to plug hearphone.
        I tried to upgrade/downgrade BIOS.
        I tried to hide the OB SSD from BIOS.
        I can't get a sound out of this box.

        I keep various informations (dmesg, lspci, ...) about both Eee PC here:
        I did boot the same OSes on both and issue the same commands to compare 
and find what changes.
        Install and run NetBSD/i386 on the ASUS Eee PC 900.
        Unfortunately, I have no idea.


Home | Main Index | Thread Index | Old Index