NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

kern/39038: missing backward compaatibility in pf(4)

>Number:         39038
>Category:       kern
>Synopsis:       missing backward compaatibility in pf(4)
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 25 18:15:00 +0000 2008
>Originator:     Alan Barrett
>Release:        NetBSD 4.99.66
Not much
System: NetBSD 4.99.66
Architecture: i386
Machine: i386
        The pf(4) driver in a recent kernel (4.99.66) does not support
        the ioctl requests that are used by older pfctl(1) userland

        Have /sbin/pfctl from NetBSD 4.99.63.
        Have a kernel from NetBSD 4.99.66.

        $ sudo pfctl -f /etc/pf.conf
        No ALTQ support in kernel
        ALTQ related functions disabled
        pfctl: DIOCADDRULE: Operation not supported by device
        $ sudo pfctl -s all
        pfctl: DIOCGETALTQS: Permission denied

        Provide backward compatibility in the pf(4) driver.

Home | Main Index | Thread Index | Old Index