NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bin/38493: no good audio with cdplay

>Number:         38493
>Category:       bin
>Synopsis:       no good audio with cdplay
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Apr 23 22:20:00 +0000 2008
>Release:        NetBSD 4.99.55
  Jeremy C. Reed
System: NetBSD 4.99.55 NetBSD 4.99.55 (GENERIC) #1: Mon Mar 17 
13:16:38 CDT 2008 
Architecture: x86_64
Machine: amd64
I have Toshiba Satellite A215-S7422 running NetBSD/amd64 4.99.55.
I have used cdplay many times ever since it was available -- just not on 
this system.

cdparanioa works fine to rip. (file says one track is "Claris clip art?" 
another is "RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, 
stereo 44100 Hz"

audioplay works fine to play these ripped tracks.

I use:  mixerctl -w outputs.black15.eapd=on

I have:

azalia0: codec[0] has no audio function groups
audio0 at azalia0: full duplex, independent
audio1 at pad0: half duplex

My cd is:

cd0 at atapibus0 drive 0: <MATSHITADVD-RAM UJ-850S, HB88  482625, 1.21> 
cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 2 (Ultra/33)
cd0(ixpide1:0:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using 
cd0(ixpide1:0:0):  Check Condition on CDB: 0x28 00 00 00 00 00 00 00 01 00
cd0: dos partition I/O error
cd0: transfer error, downgrading to Ultra-DMA mode 1
cd0(ixpide1:0:0): using PIO mode 4, Ultra-DMA mode 1 (using DMA)

cdplay won't work for me. No audio. (mplayer and ogg123 and audioplay all 
work for audio for me.)

I also use "digital" from interactive mode and it shows:

digital xfer:   to /dev/sound (5 frames per wakeup, 0.33330s period)

(and then doesn't show the left and right volumes.)

play shows:

cdplay: scsi cmd failed: retsts 1 status 0

cdplay: scsi cmd failed: retsts 3 status 2

status shows it is playing and also I can hear the hardware doing 

I also tried many different digital "frame" numbers.
I was able to hear some sporadic, choopy music with:
25, 20, 15, 10, 12. But I can't repeat and I tried many different
numbers beyond those from 1 to 50.

Also if I use interactive mode, sometimes running stop or digital multiple 
times have no effect until I quit and re-run cdplay.


Home | Main Index | Thread Index | Old Index