NetBSD-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

port-i386/37813: 4.0 kernel crashes on i386

>Number:         37813
>Category:       port-i386
>Synopsis:       4.0 kernel crashes on i386
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    port-i386-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jan 19 22:00:07 +0000 2008
>Originator:     Morten Skarstad
>Release:        4.0
n/a, since kernel crashed during boot. The release is NetBSD 4.0 i386.
After installation, NetBSD crashes during boot on my old Pentium II computer 
and drops me to a db> terminal. Somebody suggested that it might be flaky RAM 
or HDD causing the problem, but several passes of Memtest86, a full read/write 
surface test of the HDD and repeated attempts at reinstalling NetBSD has not 
solved the problem. I have also tried using the NOACPI kernel.

dmesg and bt output follows:

db> dmesg
Copyright (c) 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005,
    2006, 2007
    The NetBSD Foundation, Inc.  All rights reserved.
Copyright (c) 1982, 1986, 1989, 1991, 1993
    The Regents of the University of California.  All rights reserved.

NetBSD 4.0 (GENERIC) #0: Sun Dec 16 00:20:10 PST 2007
total memory = 319 MB
rbus: rbus_min_start set to 0x40000000
avail memory = 303 MB
timecounter: Timecounters tick every 10.000 msec
timecounter: Timecounter "i8254" frequency 1193182 Hz quality 100
BIOS32 rev. 0 found at 0xfd790
mainbus0 (root)
cpu0 at mainbus0: (uniprocessor)
cpu0: Intel Pentium II (686-class), 348.22 MHz, id 0x651
cpu0: features 183f9ff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,SEP,MTRR>
cpu0: features 183f9ff<PGE,MCA,CMOV,PAT,PSE36,MMX>
cpu0: features 183f9ff<FXSR>
cpu0: I-cache 16 KB 32B/line 4-way, D-cache 16 KB 32B/line 4-way
cpu0: L2 cache 512 KB 32B/line 4-way
cpu0: ITLB 32 4 KB entries 4-way, 2 4 MB entries fully associative
cpu0: DTLB 64 4 KB entries 4-way, 8 4 MB entries 4-way
cpu0: 32 page colors
acpi0 at mainbus0: Advanced Configuration and Power Interface
acpi0: using Intel ACPI CA subsystem version 20060217
acpi0: X/RSDT: OemId <PTLTD ,  RSDT  ,00000000>, AslId < LTP,00000000>
acpi0: SCI interrupting at int 9
acpi0: fixed-feature power button present
timecounter: Timecounter "ACPI-Safe" frequency 3579545 Hz quality 900
ACPI-Safe 24-bit timer
mpacpi: could not get bus number, assuming bus 0
LNKB: ACPI: Found matching pin for 0.14.INTA at func 0: 10
LNKC: ACPI: Found matching pin for 0.15.INTA at func 0: 5
LNKD: ACPI: Found matching pin for 0.7.INTD at func 2: 9
ACPI Object Type 'Processor' (0x0c) at acpi0 not configured
PNP0A03 [PCI/PCI-X Host Bridge] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
PNP0C0F [PCI interrupt link device] at acpi0 not configured
ACPI Object Type 'Power' (0x0b) at acpi0 not configured
PNP0C0B [ACPI Fan] at acpi0 not configured
pckbc1 at acpi0 (PNP0303): kbd port
pckbc1: io 0x60,0x64 irq 1
pckbc2 at acpi0 (PNP0F13): aux port
pckbc2: irq 12
PNP0201 [EISA DMA Controller] at acpi0 not configured
PNP0B00 [AT Real-Time Clock] at acpi0 not configured
PNP0000 [AT Interrupt Controller] at acpi0 not configured
npx1 at acpi0 (PNP0C04)
npx1: io 0xf0-0xff irq 13
npx1: reported by CPUID; using exception 16
attimer1 at acpi0 (PNP0100): AT Timer
attimer1: io 0x40-0x43 irq 0
pcppi1 at acpi0 (PNP0800)
pcppi1: io 0x61
pcppi1: children must have an explicit unit
midi0 at pcppi1: PC speaker (CPU-intensive output)
sysbeep0 at pcppi1
PNP0C02 [Plug and Play motherboard register resources] at acpi0 not configured
PNP0A06 [Generic Container Device] at acpi0 not configured
PNP0700 [PC standard floppy disk controller] at acpi0 not configured
PNP0501 [16550A-compatible COM port] at acpi0 not configured
PNP0400 [Standard LPT printer port] at acpi0 not configured
PNP0501 [16550A-compatible COM port] at acpi0 not configured
acpitz0 at acpi0: ACPI Thermal Zone
acpitz0: unable to get polling interval; using default of 30.0s
acpitz0: active cooling level 0: 26.8C
acpitz0: critical 31.8C
pckbd0 at pckbc1 (kbd slot)
pckbc1: using irq 1 for kbd slot
wskbd0 at pckbd0 mux 1
pms0 at pckbc1 (aux slot)
pckbc1: using irq 12 for aux slot
wsmouse0 at pms0 mux 0
pcppi1: attached to attimer1
pci0 at mainbus0 bus 0: configuration mode 1
pci0: i/o space, memory space enabled, rd/line, rd/mult, wr/inv ok
pchb0 at pci0 dev 0 function 0
pchb0: Intel 82443BX Host Bridge/Controller (rev. 0x02)
agp0 at pchb0: aperture at 0xf8000000, size 0x4000000
ppb0 at pci0 dev 1 function 0: Intel 82443BX AGP Interface (rev. 0x02)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
vga1 at pci1 dev 0 function 0: Matrox MGA G200 AGP (rev. 0x01)
wsdisplay0 at vga1 kbdmux 1
wsmux1: connecting to wsdisplay0
wskbd0: connecting to wsdisplay0
piixpcib0 at pci0 dev 7 function 0
piixpcib0: Intel 82371AB (PIIX4) PCI-ISA Bridge (rev. 0x02)
uvm_fault(0xc0a0cbc0, 0, 1) -> 0xe
uvm_fault(0xc0a0cbc0, 0, 1) -> 0xe
uvm_fault(0xc0a0cbc0, 0, 1) -> 0xe
db> bt
strlen(c0901dc2,5,0,0,c0af58b4) at netbsd:strlen+0x10
printf(c0901dc2,1c,c0af59bc,ffffffff,8d5bd4) at netbsd:printf+0x46
agp_generic_enable(c1077000,c11fb700,c0af59bc,c09698e0,c11fb700) at netbsd:agp_g
config_attach_loc(c1077000,c096c520,c0af59f8,c0af59bc,c050c6d0) at netbsd:config
pci_probe_device(c1077000,80003800,0,0,0) at netbsd:pci_probe_device+0x22d
pci_enumerate_bus(c1077000,c078a7cc,0,0,c11e6fc0) at netbsd:pci_enumerate_bus+0x
pcirescan(c1077000,c08d606a,c078a7cc,c0968d40,c1077000) at netbsd:pcirescan+0x24

config_attach_loc(c11e6fc0,c096bc38,0,c0af5b18,c050f5f0) at netbsd:config_attach
config_found_ia(c11e6fc0,c08d6237,c0af5b18,c050f5f0,0) at netbsd:config_found_ia
mainbus_attach(0,c11e6fc0,0,c0968d20,c11e6fc0) at netbsd:mainbus_attach+0x2c9
config_attach_loc(0,c096bc20,0,0,0) at netbsd:config_attach_loc+0x340
config_attach(0,c096bc20,0,0,c0af2010) at netbsd:config_attach+0x2c
config_rootfound(c08d589d,0,c0af5c28,c043e22f,c08e37d1) at netbsd:config_rootfou
cpu_configure(c08e37d1,0,0,bfeff000,c0af2010) at netbsd:cpu_configure+0x27
configure(0,1,0,0,ffff) at netbsd:configure+0x2f
main(fbff,c01002d2,0,0,0) at netbsd:main+0xdd



Home | Main Index | Thread Index | Old Index