Subject: kern/37632: Unable to boot 4.0 using "Silicon Image 3112A"-based SATA controller
To: None <,,>
From: None <>
List: netbsd-bugs
Date: 12/28/2007 02:45:01
>Number:         37632
>Category:       kern
>Synopsis:       Unable to boot 4.0 using "Silicon Image 3112A"-based SATA controller
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Dec 28 02:45:01 +0000 2007
>Originator:     Zbigniew Baniewski
>Release:        4.0 installation CD
While trying to install newest version of NetBSD - 4.0 - I noticed the problem, probably with the driver for SiI-3112A SATA controller. After usual boot messages, the boot process halts after HDD-recognition lines (if USB has been enabled, some more lines about recognized USB devices will follow), then booting seems to be "frozen" - although the system isn't "hung". I tried all the three kernels, present on install-CD (generic, laptop, noapci) - still the same effect: it's unable to finish the boot stage.

After I press <Control>-<Alt>-<Esc>, and after I type "bt", there is a message:

cpu_Debugger(2,c103400a,20,c0ac0508,c0a024a0) at netbsd:cpu_Debugger+0x4
wskbd_translate(0,c05033a0,c0ac0544,63a1b2,63a1af) at netbsd:wskbd_translate+0xfc
wskbd_input(c1025a00,2,1,1,2aca) at netbsd:wskbd_input+0x4c
pckbd_input(c102b200,1,1,60,16b) at netbsd:pckbd_input+0x30
pckbcintr(c102b280,6,10,30,10) at netbsd:pckbcintr+0x8c
Xintr_legacy1() at netbsd:Xintr_legacy1+0xa9
--- interrupt ---
DDB lost frame for netbsd:Xintr_legacy11+0xea, trying 0xc0ac0594
Xintr_legacy11() at netbsd:Xintr_legacy11+0xea
--- interrupt ---

The problem disappeard, when I unplugged my HDD (WD 40 GB) from the SATA controller (while leaving the card still plugged in the slot) before new booting attempt.

I would to add here, that I've checked the older 3.1 installation CD, with exactly the same result: no chance to install.
Must be possible to repeat using the same controller and HDD; just using the install-CD the way described above.