Subject: install/37156: RC3 breaks something that worked in Beta2
To: None <,,>
From: None <>
List: netbsd-bugs
Date: 10/20/2007 00:55:00
>Number:         37156
>Category:       install
>Synopsis:       RC3 breaks something that worked in Beta2
>Confidential:   no
>Severity:       critical
>Priority:       medium
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Oct 20 00:55:00 +0000 2007
>Originator:     Randolf Richardson
>Release:        NetBSD 4 RC3 and NetBSD 4 beta2 200708030002z
Inter-Corporate Computer & Network Services, Inc.
NetBSD  4.0_BETA2 NetBSD 4.0_BETA2 (GENERIC.MP) #0: Fri Aug 3 20:01:40 PDT 2007  builds@wb34:/home/builds/ab/netbsd-4/i386/200708030002Z-obj/home/builds/ab/netbsd-4/src/sys/arch/i386/compile/GENERIC.MP i386
My system has an Intel server motherboard with 2 GBs of RAM, and an LSI Logic SAS3041E-R SASCSI controller with two SASCSI hard drives (mirrored by hardware).

When I install NetBSD 4 Beta2 (200708030002z) from the i386 ISO (burned on a CD), it works fine.  Using the NetBSD 4 RC3 i386 ISO results in the system not being bootable.

During the installation process, I noticed that the final step when files are being copied (and the progress bar appears), with RC3 it slips by so quickly that it seems like it was missed; with Beta2 a few moments are needed to copy files to the hard drive.

I suspect that something has changed with the drivers that result in files not being copied in RC3 but some return codes somewhere aren't being checked properly.  When Beta2 worked I was so happy because NetBSD 3 doesn't support my controller card (OpenBSD does, but I need to use NetBSD).

Installation.  Partition setup is okay, just copying files seems to be the problem.
Unknown, but I suspect that the driver has something to do with it.  FYI, the driver for this controller proved to be stable in my testing Beta2 with heavy disk I/O and many reboots (plus a few simulated power outages by simply pulling the plug during the heavy disk I/O).

Thanks in advance.