Subject: bin/37024: ath(4) manual page updates
To: None <,>
From: None <>
List: netbsd-bugs
Date: 09/25/2007 15:10:04
>Number:         37024
>Category:       bin
>Synopsis:       ath(4) appears to be out of date in 4.0_RC1
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    bin-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Sep 25 15:10:02 +0000 2007
>Originator:     Giles Lean
>Release:        NetBSD 4.0_RC1
System: NetBSD 4.0_RC1 NetBSD 4.0_RC1 (AMETHYST-$Revision: 1.25 $) #2: Tue Sep 25 10:00:37 EST 2007 i386
Architecture: i386
Machine: i386
The ath(4) manual page says that encryption is not supported at
this time:

     "AR5211 and AR5212 support the AES, TKIP, and Michael crypto-
      graphic operations required for WPA but at this time the driver
      does not support them.  To enable encryption, use ifconfig(8)."

wpa_supplicant appears to work just fine, but isn't mentioned.

(I was very pleasantly surprised how easy it was to set up WPA-PSK
with an Atheros based card "TP-Link TL-WN651G Ver. 1.5". It all Just

$ man ath
Change the referenced text to refer to wpa_supplicant(8) and