Subject: Re: kern/36505: java doesn't work anymore
To: None <,,>
From: Bernd Ernesti <>
List: netbsd-bugs
Date: 06/24/2007 05:20:02
The following reply was made to PR kern/36505; it has been noted by GNATS.

From: Bernd Ernesti <>
Subject: Re: kern/36505: java doesn't work anymore
Date: Sun, 24 Jun 2007 07:19:33 +0200

 On Sat, Jun 23, 2007 at 11:10:03PM +0000, Andrew Doran wrote:
 >  I may be stating the obvious, but: that makes some sense, since the server
 >  vm doesn't support whatever -Xshare:dump does, and java chooses which vm to
 >  use depending on how much memory the machine has. Does it support -client I
 >  wonder? I'm not discounting the fact that there may be a problem with the
 >  reported amount of memory, but for building the package we could always
 >  supply -client.
 I mentioned when I send the pr that it works with -client, but I also said that
 it worked without the -client option in the past, even with the same binaries.
 pkgsrc does use -Xshare:dump since 2004 for the 1.5 package.
 Oh, the /emul/linux/proc/meminfo report seemms to not be the root cause of
 this problem.
 I just booted with a non MP kernel and it works now.
 The MP kernel which doesn't work is based on the single CPU kernel, but has
 the following additonal kernel options:
 options         DIAGNOSTIC
 options         LOCKDEBUG
 options         DEBUG
 options         MULTIPROCESSOR
 options         MPDEBUG
 options         MPVERBOSE
 I just compiled another kernel based on the MP kernel config, where I only
 removed the MULTIPROCESSOR option and this one still works.
 So it is a problem with MULTIPROCESSOR and that I have a dual core cpu.