Subject: Re: bin/36506: /etc/rc.d/amd prohibits reboot if amd owns /home
To: None <,,>
From: Christos Zoulas <>
List: netbsd-bugs
Date: 06/18/2007 17:23:37
On Jun 18,  9:20pm, (Matthias Scheler) wrote:
-- Subject: Re: bin/36506: /etc/rc.d/amd prohibits reboot if amd owns /home

| The following reply was made to PR bin/36506; it has been noted by GNATS.
| From: Matthias Scheler <>
| To:
| Cc: 
| Subject: Re: bin/36506: /etc/rc.d/amd prohibits reboot if amd owns /home
| Date: Mon, 18 Jun 2007 22:19:23 +0100
|  On Mon, Jun 18, 2007 at 09:27:41PM +0200, Hauke Fath wrote:
|  > > Why should that block the reboot?
|  > Good question. It shouldn't. All I know is that it does.
|  I've tried that change. And my usual sequence is to "su" from my
|  normale account with a NFS mounted "/home" and use "shutdown"
|  afterwards. And I've never encountered problems with that.
|  What operating system are you running on the client? The latest version
|  of amd(8) got pulled up into "netbsd-3" after 3.1 was released.
|  > > This happened because the amd(8) process got terminated but the
|  > > pseudo NFS mounts were still active. The kernel tried to unmount
|  > > them but didn't succeed because the NFS request didn't get handled.
|  > 
|  > We're relying heavily on amd(8) at work for mounting user homes as well as
|  > general purpose fileserver storage on NetBSD 1.6 - 3, and RedHat / Debian
|  > Linuxes.
|  I have all the home directories and a lot of other directories mounted
|  via amd(8), too.
|  > I don't debate the scenario you mention is possible, but I haven't seen it.
|  It only happens to me if the machine has been running for a few weeks.
|  	Kind regards

It happens when processes are keeping the nfs directories busy. I think
that most of the fixes are in the newest stable release, but I will
import a newer one.