Subject: port-macppc/34498: Netbsd 3.1RC2/macppc is powered off during boot of the installation kernel on powerbook5,8
To: None <,,>
From: None <>
List: netbsd-bugs
Date: 09/08/2006 22:35:00
>Number:         34498
>Category:       port-macppc
>Synopsis:       Netbsd 3.1RC2/macppc is powered off during boot of the installation kernel on powerbook5,8
>Confidential:   no
>Severity:       critical
>Priority:       high
>Responsible:    port-macppc-maintainer
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Sep 08 22:35:00 +0000 2006
>Originator:     Hilmar Böhm
>Release:        3.1RC2
-'uname -a is not possible-
Apple PowerBokk5,8: - post-October-2005 System, bought Nov. 2005, 15", 1,67GHz PowerPC processor, 2GB Memory, CD/DVD Superdrive, 120GB internal HD.
Used: NetBSD 3.1RC2 release candidate iso image ( )

Apple Open Firmware :
Apple PowerBoot 5,8 4.9.6f0 BootROM built on 10/05/05 at 16:45:50
Copyright 1994-2005 Apple Computer, Inc.

Welcome to Open Firmwarem the system time and date is: 09/08/2006 22:23:47

Symptom: During boot of the installation kernel the system is (completely) powered off. 
What I tried:
1. Boot from CD-ROM (see above)by means of (from OFW3 cmmand line):
> boot cd:, ofwboot.xcf --> The system is switched off after a few lines of kernel output. Lines go by very fast, so no detail can be seen.

2. - Copied from Inst-CD: "ofwboot.xcf", "netbsd-GENERIC-MD.gz", "netbsd-GENERIC_MD.symbols.gz" over to root dir. of MAC OS X Boot partition (first HPFS partition on disk) and 
- renamed netbsd-GENERIC_MD.gz to netbsd-gz and
- issued the OFW3 command: > boot hd:,ofwboot.xcf netbsd.gz

3. The screen resolution changes from standard PB-resolution to a lower resolution (bigger characters) with white screen background and kernel output starts. The Output on screen is to fast to recognize output in detail. I tried to take a picture from the screen with my mobile phone camera. 
The last lines are:
uhub1 at usb1
uhub1: NEC OHCI ...
ehci0: 2 ports ...
ehci0 at pci1 dev...
ehci0: interruption
ehci0:  BIOS has...
ehci0: EHCI version...
usb20: companion....
uhub at ehci0...
(the system is switched off here (power off))

I can reproduce this behaviour with NetBSD 2.1, 3.0 and 3.0.1 also, ecactly same behaviour.

The only reference to this problem I saw on the port-macppc Mailing List was: 29.01.2001 - Richard M Kreuter - "Re: Powerbook 15 XFree". No solution!

See Description above and use the above mentioned Hardware!