Subject: Re: port-i386/32393
To: None <,,>
From: =?ISO-8859-1?Q?St=E9phane_Witzmann?= <>
List: netbsd-bugs
Date: 01/02/2006 07:14:43
The following reply was made to PR port-i386/32393; it has been noted by GNATS.

From: =?ISO-8859-1?Q?St=E9phane_Witzmann?= <>
Subject: Re: port-i386/32393
Date: Sun, 1 Jan 2006 19:20:41 +0100

 > I'm gonna take a look at your problem, see if I can reproduce it with
 > 2.1, 3.0 on my laptop.
 My userland and packages (from 2005Q3) are 2.1, but I also tried with
 a 3.0 kernel.
 By the way, my sound card is an auich(4).
 auich0 at pci0 dev 31 function 5: i82801DB/DBM (ICH4/ICH4M) AC-97 Audio
 auich0: interrupting at irq 5
 auich0: ac97: CXT48 codec; reserved, headphone, 18 bit DAC, 18 bit
 ADC, no 3D stereo
 auich0: ac97: ext id a04<AC97_23,AMAP,SPDIF>
 The flash file I used for testing can be found at:
 - tried pkgsrc/multimedia/flashplayer: I couldn't get a sound out of
 it, although the rest seemed to work. audioctl reported that the
 device was open but apparently it was not playing and the rates were
 not set.
 - tried pkgsrc/www/firefox-bin, let it install the "official" flash
 player automatically (in my home dir, I believe). Flash worked, and I
 got sound. Playing the above file seemed to work well with the 3.0
 kernel. However, I have seen problems with the 2.1 kernel:
     - a/v sync is gradually lost, video seems to play only one frame
 out of many, although the general speed is preserved.
     - once playing is finished [see swf file], it restarts strangely
 (it is not supposed to do so), I mean first you hear the first 0.1s of
 the sound, then the first (not "next") 0.2s, etc...
 In summary, I have not been able to reproduce the problem as described
 in the original PR (maybe because my sound card is different), but I
 have found a problem in 2.1 that seems to have been fixed in 3.0.