Subject: Wireless usb mouse detection prob? Strange usb port disabling.
To: None <netbsd-bugs@netbsd.org>
From: Danny Beaudoin <beaudoin_danny@hotmail.com>
List: netbsd-bugs
Date: 09/28/2005 01:13:59
Hi all,

I have recently acquired a Microsoft Standard Wireless Optical Mouse (USB) 
(not really useful but hereís the product page: 
http://www.microsoft.com/products/info/product.aspx?view=22&pcid=ad417eb1-0405-45bf-8847-04125e1d9052&type=ovr).
I used it in Windows XP without a problem; same under Linux (used it 
temporarily because I didnít have the net to download NetBSD). I tried with 
NetBSD 2.0.2 and 2.1RC5, thereís no way Iíve been able to make it work. I 
know itís recognized (well?) from the dmesg (I include USB info):

[USB]
uhci1 at pci0 dev 16 function 1: VIA Technologies VT83C572 USB Controller 
(rev. 0x81)
uhci1: interrupting at irq 11
usb1 at uhci1: USB revision 1.0
uhub1 at usb1
uhub1: VIA Technologies UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered

[MOUSE]
uhidev0 at uhub1 port 1 configuration 1 interface 0
uhidev0: Microsoft Microsoft USB Wireless Mouse, rev 2.00/0.17, addr 2, 
iclass 3/1
uhidev0: 23 report ids
ums0 at uhidev0 reportid 17: 5 buttons and Z dir.
wsmouse0 at ums0 mux 0
uhid0 at uhidev0 reportid 18: input=0, output=0, feature=1
uhid1 at uhidev0 reportid 19: input=1, output=0, feature=0
uhid2 at uhidev0 reportid 20: input=1, output=0, feature=0
uhid3 at uhidev0 reportid 21: input=3, output=0, feature=0
uhid4 at uhidev0 reportid 23: input=0, output=0, feature=1

I donít understand why it reports it has 5 buttons: left, right and scroll 
wheel makes 3 buttons, right? The only difference with my previous mouse is 
the looks, brand and the wire, and itís detected as follows:

uhidev0: Logitech USB-PS/2 Optical Mouse, rev 2.00/11.10, addr 2, iclass 3/1
ums0 at uhidev0: 3 buttons and Z dir.

Maybe thatís why it doesnít work: it might not even be detected correctly. 
If you believe this is the problem, how could I make it be correctly 
detected? Does this have anything to do with reportids?

Anyway, Iíve configured X using the wsmouse, Auto and Microsoft protocol and 
Iíve tried both /dev/wsmouse and /dev/wsmouse0. With the normal wsmouse 
protocol configurations, the wired mouse works perfectly in X but not the 
wireless one with anything.

I also want to report a strange behavior: USB ports get disabled after 
connecting a mouse in the same port my wireless mouse was. (Maybe since it 
doesnít work because of the way it is detected, but then why would the 
kernel report a device problem for the _following_ device? See below.)

-In X, the wired mouse works perfectly.
-Still in X, replacing the wired mouse by the wireless mouse fails: the 
mouse is detected but unusable (I must always restart the X server to use a 
newly connected mouse, even if itís the same device on the same USB port. I 
believe fixing that would be nice.)
-Reconnecting the wired mouse also fails: detach message as usual but then 
there is no power to the wired mouse and the kernel finally says:
uhub1: device problem, disabling port 1

In conclusion, how, if this is the problem, may I get my wireless mouse 
correctly detected? And the USB disabling seems odd, is this normal?

Thanks