Subject: kern/30880: wm(4) on fiber boots up with media inactive
To: None <,,>
From: None <>
List: netbsd-bugs
Date: 07/31/2005 01:03:00
>Number:         30880
>Category:       kern
>Synopsis:       wm(4) on fiber boots up with media inactive
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jul 31 01:03:00 +0000 2005
>Originator:     Ross Harvey
>Release:        NetBSD-current circa 2005-7-30
NetBSD random 3.99.7 NetBSD 3.99.7 (bkb) #29: Thu Jul 28 16:26:44 PDT 2005  ross@batbox:/usr/ross/bkb i386

After a reboot, media state is inactive. I have tried various 
ifconfig(8) commands with no success. (Manual media setting doesn't

However, it links up just fine if you simply unplug and replug the
fiber, or if you power cycle the switch.

This problem occurs with a Netgear GS504. I have not tried any
other switches.

The problem does _not_ occur if I just plug the two wm(4) devices in
back-to-back with no switch.

This may be related to kern/30490.

wm1 at pci2 dev 8 function 0: Intel i82544EI 1000BASE-X Ethernet, rev. 2
wm1: interrupting at irq 10
wm1: 32-bit 33MHz PCI bus
wm1: 64 word (6 address bits) MicroWire EEPROM
wm1: Ethernet address 00:07:e9:17:69:90
wm1: 1000baseSX, 1000baseSX-FDX, auto