Subject: bin/30632: pkgtools in netbsd-2 branch are old
To: None <,>
From: None <>
List: netbsd-bugs
Date: 06/29/2005 16:51:00
>Number:         30632
>Category:       bin
>Synopsis:       pkgtools in netbsd-2 branch are old
>Confidential:   no
>Severity:       non-critical
>Priority:       medium
>Responsible:    bin-bug-people
>State:          open
>Class:          change-request
>Submitter-Id:   net
>Arrival-Date:   Wed Jun 29 16:51:00 +0000 2005
>Originator:     Greg Troxel
>Release:        2.0_STABLE NetBSD
        Greg Troxel <>
System: NetBSD [redacted] 2.0_STABLE NetBSD 2.0_STABLE (GENERIC) #0: Wed Jun 29 00:58:52 EDT 2005 root@[redacted]:/n1/obj/auto-2-0/sparc64/sys/arch/sparc64/compile/GENERIC sparc64

Architecture: sparc64
Machine: sparc64
The pkg tools in src/usr.sbin/pkg_install are old, and this results in
having to rebuild pkgsrc/pkgtools/pkg_install.

Do a build/install from the head of the netbsd-2 branch, and try to
install a package.

cd src/usr.sbin/pkg_install/lib && cvs log version.h


verify that changes in src/usr.sbin/pkg_install are appropriate for
netbsd-2 and pullup to branch.  (I'm not submitting a pullup request
myself because I don't understand the pkg_install tools well enough.)

It seems that netbsd-3 also needs pullups.