Subject: kern/30615: problems with PATA(IDE) HDD via USB adaptor
To: None <,,>
From: None <>
List: netbsd-bugs
Date: 06/28/2005 01:33:00
>Number:         30615
>Category:       kern
>Synopsis:       problems with PATA(IDE) HDD via USB adaptor
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    kern-bug-people
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jun 28 01:33:00 +0000 2005
>Release:        NetBSD 2.0.2
System: NetBSD 2.0.2 NetBSD 2.0.2 (GENERIC) #0: Wed Mar 23 08:53:42 UTC 2005 i386
Architecture: i386
Machine: i386
	I have a USB/PATA adaptor in an i386 box - the adaptor is an 
	ViPower 1028LSF USB2 mobile rack unit - it worked at first, 
	and I have a couple of 160GB HDDs (IDE/PATA) in some caddies
	that I swap over to use as dump-file reposiories for backups.

	I'm seeing this in /var/log/messages at the moment :

	Jun 28 11:18:00 mail /netbsd: umass0: BBB reset failed, TIMEOUT
	Jun 28 11:19:05 mail /netbsd: umass0: BBB bulk-in clear stall failed, TIMEOUT
	Jun 28 11:20:15 mail /netbsd: umass0: BBB bulk-out clear stall failed, TIMEOUT
	Jun 28 11:22:25 mail /netbsd: umass0: BBB bulk-out stall clear failed, TIMEOUT
	and the device is refusing to mount.  I've seen a thread on
	netbsd-help discussing something very similar :
	but that didn't seem to have any resolution, I think this 
	may be the same issue.

	I think a reboot of the server will get it going again 0 I'll
	test tonight (the box is in production at a client site), btu
	that's no fix!