Subject: Re: kern/28375
To: None <>
From: None <>
List: netbsd-bugs
Date: 11/29/2004 20:28:05
> This should be fixed now - could you update your source, make sure that you have
> options PFIL_HOOKS in your kernel config, and try again?

It's really getting better here. I really appreciate it and thank you
for your work.

But I still found a problem, sorry :(
Detaching and reattaching indeed works like a charm now. But when I
reattach the ethernet device I do not have internet connection
anymore. Of course I cannot have internet connection anmore, no
problem with this.

So I tried to bring it up again. Call me silly, but
I tried 'ifconfig pppoe0 up' first. And this dumps straight away.
I would not mind if this command yields an error or does not work. But
I think it should not kernel panik at all ;)

Here's the callstack of my fresh new coredump.

#0  0x00000000 in ?? ()
(gdb) bt
#0  0x00000000 in ?? ()
#1  0xc0524000 in ?? ()
#2  0xc02e5835 in cpu_reboot ()
#3  0xc026a0bb in panic ()
#4  0xc02ed6d5 in trap ()
#5  0xc0102dd9 in calltrap ()
#6  0xc02b8941 in pppoe_disconnect ()
#7  0xc026369a in softclock ()
#8  0xc02e228c in softintr_dispatch ()
#9  0xc0102aee in Xsoftclock ()