Subject: install/26931: sysinst 'update' fails to update /etc properly
To: None <>
From: None <>
List: netbsd-bugs
Date: 09/12/2004 21:54:50
>Number:         26931
>Category:       install
>Synopsis:       sysinst 'update' fails to update /etc properly
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Sep 12 21:08:00 UTC 2004
>Originator:     David Laight
>Release:        NetBSD 2.0_BETA
Architecture: i386
Machine: i386
	sysinst 'install' runs the old copy of /etc/postinstall, not the
	copy from the set being installed.
	This means that the wrong actions are performed.
	In particular MAKEDEV doesn't get updated leaving a broken
	MAKEDEV script (one that the /bin/sh won't run).
	There maye be other problems.....
	Use sysinst to upgrade a system that has anything other than
	2.0 or 'current' installed on it.
	Should be fixed by rev 1.130 of src/distrib/utils/sysinst/util.c
	The one-line change of this revision is enough.
	(note this change is currently untested, and I am unlikely to be
	able to test it - it is, hovwever, unlikely to be completely broken)