Subject: xsrc/26487: Duplicated symbol in libxtt.a.
To: None <>
From: None <>
List: netbsd-bugs
Date: 07/31/2004 07:08:01
>Number:         26487
>Category:       xsrc
>Synopsis:       Duplicated symbol in libxtt.a.
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    xsrc-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sat Jul 31 05:08:00 UTC 2004
>Originator:     Juan RP
>Release:        NetBSD 2.0_BETA
    Juan RP <>
System: NetBSD Mandylion 2.0_BETA NetBSD 2.0_BETA (Mandylion) #17: Tue Jul 27 04:14:53 CEST 2004 juan@Mandylion:/home/src/obj/sys/arch/i386/compile/Mandylion i386
Architecture: i386
Machine: i386

	Since XFree86 was upgraded to 4.4.0, I'm seeing this error
	when the freetype and xtt modules are loaded. The X server fails
	to start with the following output:

XFree86 Version 4.4.0
Release Date: 29 February 2004
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: NetBSD/i386 2.0F [ELF] The NetBSD Foundation, Inc.
Current Operating System: NetBSD Nocturno 2.0G NetBSD 2.0G (Nocturno) #31: Sat Jul 31 05:09:09 CEST 2004  juan@Nocturno:/m/obj/sys/arch/i386/compile/Nocturno i386
Build Date: 27 June 2004
Changelog Date: 29 February 2004
        Before reporting problems, check http://www.XFree86.Org/
        to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/XFree86.1.log", Time: Sat Jul 31 07:00:41 2004
(==) Using config file: "/etc/X11/XF86Config"
Duplicate symbol SPropRecValList_new in /usr/X11R6/lib/modules/fonts/libxtt.a:xttmodule.o
Also defined in /usr/X11R6/lib/modules/fonts/libfreetype.a

Fatal server error:
Module load failure

When reporting a problem related to a server crash, please send
the full server output, not just the last messages.
This can be found in the log file "/var/log/XFree86.1.log".
Please report problems to

X connection to :1.0 broken (explicit kill or server shutdown).


	This is -current xsrc on a current box, but maybe 2-0 is affected too,
	that would be nice if we have this fixed before releasing 2.0.


	Put in your XF86Config:

	Load "freetype"
	Load "xtt"

	$ xinit

	Sorry, I don't know.