Subject: install/25235: improper boot block installation on 2.0beta
To: None <>
From: None <>
List: netbsd-bugs
Date: 04/18/2004 23:34:28
>Number:         25235
>Category:       install
>Synopsis:       when doing a full-disk install, some boot block isn't being installed
>Confidential:   no
>Severity:       serious
>Priority:       high
>Responsible:    install-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Apr 19 03:35:01 UTC 2004
>Originator:     Steven M. Bellovin
>Release:        NetBSD 2.0_BETA
System: NetBSD 2.0_BETA NetBSD 2.0_BETA (CHADASH) #0: Sun Apr 18 20:49:33 EDT 2004 i386
Architecture: i386
Machine: i386
	When doing a new installation and specifying "NetBSD uses the
	whole disk", some boot block is not being installed.  I'm not
	certain which; I did see /boot on the drive.  As a possible clue:
	the first time I tried this, the disk had had Linux installed;
	I got a GRUB prompt, but couldn't make it do anything past that.
	When I copied /dev/zero to the beginning of the disk and retried
	the installation, I got nothing at boot time.
	See above
	I ran 'installboot' and 'fdisk'; one or both fixed the problem.
 	18 April 2004