Subject: pkg/24840: libgnomeui doesn't compile
To: None <gnats-bugs@gnats.netbsd.org>
From: None <alebret@ifrance.com>
List: netbsd-bugs
Date: 03/18/2004 17:09:41
>Number:         24840
>Category:       pkg
>Synopsis:       libgnomeui can't get compiled
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Thu Mar 18 16:11:00 UTC 2004
>Closed-Date:
>Last-Modified:
>Originator:     Arnaud Lebret
>Release:        NetBSD 1.6.2
>Organization:
	
>Environment:
System: NetBSD fin-lebret.beauvais.fr 1.6.2 NetBSD 1.6.2 (ABOULAFIA) #0: Wed Mar 17 17:10:02 CET 2004 root@fin-lebret.beauvais.fr:/usr/src/sys/arch/i386/compile/ABOULAFIA i386
Architecture: i386
Machine: i386
>Description:
fin-lebret% pwd                                                                         /usr/pkgsrc/devel/libgnomeui
/usr/pkgsrc/devel/libgnomeui
fin-lebret% sudo make install clean                                                     /usr/pkgsrc/devel/libgnomeui
===> Checking for vulnerabilities in libgnomeui-2.4.0.1nb5
===> Building for libgnomeui-2.4.0.1nb5
/usr/pkg/bin/gmake  all-recursive
gmake[1]: Entering directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1'
Making all in libgnomeui
gmake[2]: Entering directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1/libgnomeui'
Making all in pixmaps
gmake[3]: Entering directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1/libgnomeui/pixmaps'
gmake[3]: Rien  faire pour  all .
gmake[3]: Leaving directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1/libgnomeui/pixmaps'
gmake[3]: Entering directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1/libgnomeui'
/bin/sh ../libtool --mode=link gcc  -O2 -I/usr/pkg/include -I/usr/pkg/include/freetype2 -I/usr/include -I/usr/pkg/include/libglade-2.0 -L/usr/pkg/lib -Wl,-R/usr/pkg/lib -L/usr/lib -Wl,-R/usr/lib -L/usr/X11R6/lib -Wl,-R/usr/X11R6/lib -o libgnomeui-2.la -rpath /usr/pkg/lib -version-info 400:0:400         -no-undefined   -export-symbols-regex "^[^_].*" libgnomeui-access.lo gnometypebuiltins.lo gnome-about.lo gnome-app.lo gnome-app-helper.lo gnome-app-util.lo gnome-appbar.lo gnome-stock-icons.lo gnome-color-picker.lo gnome-dateedit.lo gnome-dialog.lo gnome-dialog-util.lo gnome-druid.lo gnome-druid-page.lo gnome-druid-page-edge.lo gnome-druid-page-standard.lo gnome-entry.lo gnome-file-entry.lo gnome-font-picker.lo gnome-gconf-ui.lo gnome-href.lo gnome-ice.lo gnome-marshal-main.lo gnome-messagebox.lo gnome-mdi.lo gnome-mdi-child.lo gnome-mdi-generic-child.lo gnome-mdi-session.lo gnome-pixmap.lo gnome-pixmap-entry.lo gnome-popup-menu.lo gnome-propertybox.lo gnome-scores.lo gnome-th!
 eme-parser.lo gnome-thumbnail.lo gnome-thumbnail-pixbuf-utils.lo gnome-ui-init.lo gnometypes.lo gnome-icon-entry.lo gnome-icon-item.lo gnome-icon-list.lo gnome-icon-lookup.lo gnome-icon-sel.lo gnome-icon-theme.lo gnome-vfs-util.lo gnome-window.lo gnome-window-icon.lo gnome-password-dialog.lo gnome-authentication-manager.lo gnome-client.lo -Wl,-R/usr/pkg/lib -Wl,--export-dynamic -L/usr/pkg/lib -lbonoboui-2 -lxml2 -lz -lgnomecanvas-2 -lgnome-2 -lpopt -lart_lgpl_2 -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lpangoxft-1.0 -lpangox-1.0 -lbonobo-2 -lgnomevfs-2 -lbonobo-activation -lgconf-2 -lORBit-2 -lgthread-2.0 -lpthread -lintl -lpango-1.0 -lgobject-2.0 -lgmodule-2.0 -lglib-2.0 -liconv -lm   -ljpeg                         -L/usr/X11R6/lib -lSM -lICE -lpopt -lintl
libtool: link: `gnome-mdi.lo' is not a valid libtool object
gmake[3]: *** [libgnomeui-2.la] Erreur 1
gmake[3]: Leaving directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1/libgnomeui'
gmake[2]: *** [all-recursive] Erreur 1
gmake[2]: Leaving directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1/libgnomeui'
gmake[1]: *** [all-recursive] Erreur 1
gmake[1]: Leaving directory `/usr/pkgsrc/devel/libgnomeui/work/libgnomeui-2.4.0.1'
gmake: *** [all-recursive-am] Erreur 2
*** Error code 2

Stop.
make: stopped in /usr/pkgsrc/devel/libgnomeui
*** Error code 1

Stop.
make: stopped in /usr/pkgsrc/devel/libgnomeui
>How-To-Repeat:
Just do the same thing
>Fix:
Unknown
>Release-Note:
>Audit-Trail:
>Unformatted: