Subject: pkg/24825: xisp doesn't build (gcc3 related?)
To: None <>
From: None <>
List: netbsd-bugs
Date: 03/17/2004 14:59:43
>Number:         24825
>Category:       pkg
>Synopsis:       xisp doesn't build (gcc3 related?)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Wed Mar 17 15:00:01 UTC 2004
>Originator:     Noud de Brouwer
>Release:        1.6ZK
NetBSD 1.6ZK NetBSD 1.6ZK (ME_LAPTOP) #0: Thu Feb 26 21:32:27 CET 2004  root@ i386
gcc -Wall -O -DBINPATH=\"/usr/sbin\" -DLIBPATH=\"/usr/X11R6/libexec\" -DOPTPATH=\"/etc/ppp\" -DRUNDIR=\"/var/run\"  -DMODEM_DEVICE=\"/dev/modem\" -DHAVE_STRERROR -I/usr/X11R6/include -I/usr/X11R6/include/X11 -c xisp.c
In file included from xisp.c:25:
/usr/include/varargs.h:43:2: #error "GCC 3.3 and newer no longer implements <varargs.h>."
/usr/include/varargs.h:44:2: #error "Revise your code to use <stdarg.h>."
xisp.c:579: error: syntax error before "va_dcl"

clean install + current pkgsrc
cd /usr/pkgsrc/comms/xisp; make