Subject: Re: LiteON 52x24x52x DMA old problems
To: Maggio <>
From: Giles Lean <>
List: netbsd-bugs
Date: 03/06/2004 23:19:28

Maggio <> wrote:

> This is an OLD problem of NetBSD with the LiteON CDRW drives ,

> The problem is this :
> My model  is LiteON LTR-52246S , I use the lastest FirmWare

More likely you have a problem with the controller that drive is plugged
in to.  What type is it?  If you include the relevant boot configuration
messages from dmesg(8) or /var/run/dmesg.boot people will have more idea
what you're talking about.

Alternatively, try a different IDE interface, or even a different drive.
(If I had to change one or the other, I'd change the controller.)


NetBSD 1.6.2 (GENERIC) #1: Mon Feb 23 20:37:18 EST 2004
cpu0: Intel Celeron (Mendocino) (686-class), 398.73 MHz
ppb0 at pci0 dev 30 function 0: Intel 82801BA Hub-to-PCI Bridge (rev. 0x01)
pci1 at ppb0 bus 1
pci1: i/o space, memory space enabled
pciide0 at pci1 dev 13 function 0: Silicon Image 0680 (rev. 0x02)
pciide0: bus-master DMA support present
pciide0: primary channel configured to native-PCI mode
pciide0: using irq 9 for native-PCI interrupt
atapibus0 at pciide0 channel 0: 2 targets
cd0 at atapibus0 drive 0: <LITE-ON LTR-40125S, , ZS0K> type 5 cdrom removable
cd0: 32-bit data port
cd0: drive supports PIO mode 4, DMA mode 2, Ultra-DMA mode 2 (Ultra/33)
cd0(pciide0:0:0): using PIO mode 4, Ultra-DMA mode 2 (Ultra/33) (using DMA data transfers)

Giles Lean <>

Content-Type: application/pgp-signature

Version: GnuPG v1.2.4 (NetBSD)