Subject: pkg/24575: audio/xmms configure is not compatible with pkgsrc
To: None <>
From: None <>
List: netbsd-bugs
Date: 02/27/2004 14:06:49
>Number:         24575
>Category:       pkg
>Synopsis:       audio/xmms configure is not compatible with pkgsrc
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 27 14:07:00 UTC 2004
>Originator:     Michal Pasternak
>Release:        N/A
Slackware 9.1
audio/xmms won't build on Slackware 9.1.

"native" slackware gtk is installed in /usr/ prefix.

configure will take gtk-config from /usr/bin/, even if I set
PREFER_PKGSRC in /etc/mk.conf
Adding --with-gtk-exec-prefix=${PREFIX}/bin/ to Makefile.common doesn't 
help much. Propably my fault. Dunno.

I have removed "native" gtk and compiled pkgsrc one, worked.

I have no idea if this is the right fix, propably this switch should
be always included by gtk+/bl3, propably for some packages it will
be named different... This whole "configure" idea seems so broken :/

Propably gtk/bl3 could be re-worked in such manner so it could use 
"native" gtk, but as linux systems are way beyond being "standarized",
this could really be more trouble, than help to pkgsrc/Linux users