Subject: pkg/24409: can't install new pkgtools/pkg_install
To: None <>
From: None <>
List: netbsd-bugs
Date: 02/13/2004 16:27:01
>Number:         24409
>Category:       pkg
>Synopsis:       can't install new pkgtools/pkg_install
>Confidential:   no
>Severity:       serious
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Fri Feb 13 05:28:00 UTC 2004
>Originator:     Simon Burge
>Release:        NetBSD 1.6ZG
Wasabi Systems
System: NetBSD 1.6ZG NetBSD 1.6ZG (WALNUT-virgin)
#61: Sun Dec 21 16:41:16 EST 2003 evbppc
Architecture: powerpc
Machine: evbppc

	If I try to build a package with 20030202 package tools, it
	asks me to install newer package tools:

===> Error: The package tools installed on this system are out of date.
===> The installed package tools are dated 2003/02/02 and you must update
===> them to at least 2003/09/18 using the following command:
===>    cd /NetBSD/pkgsrc/pkgtools/pkg_install && /usr/bin/make clean && /usr/bin/make install
===> Unable to satisfy dependency: >=none

	When I do that I see:

walnut:pkgsrc/pkgtools/pkg_install 555> make 
pkg_info: option requires an argument -- e
usage: pkg_info [-BbcDdFfIikLmnpqRrSsVvh] [-e package] [-l prefix]
		pkg-name [pkg-name ...]
       pkg_info -a [flags]
===> Unable to satisfy dependency: >=none

	This error comes from mk/compiler/  Just as a guess, I tried:

walnut:pkgsrc/pkgtools/pkg_install 556> make _IGNORE_GCC=yes 
make: don't know how to make pkg_admin. Stop

make: stopped in /NetBSD/pkgsrc/pkgtools/pkg_install
*** Error code 2

	but this obviously didn't work...

	Use ~1 year old userland and try to install a new package?

	None given.

 	Kernel sources from around late December 2003
 	Userland sources from around mid February 2003
 	"pkg_info -V" reports "20030202"