Subject: pkg/24169: xcdplayer (current) doesn't build (GCC 3.3 related)
To: None <>
From: None <>
List: netbsd-bugs
Date: 01/20/2004 21:17:38
>Number:         24169
>Category:       pkg
>Synopsis:       xcdplayer (current) doesn't build (GCC 3.3 related)
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Tue Jan 20 21:18:00 UTC 2004
>Originator:     Noud de Brouwer
>Release:        1.6ZG
NetBSD host016.template 1.6ZG NetBSD 1.6ZG (GENERIC.MP) #0: Sun Jan 18 17:43:12 CET 2004  root@:/usr/src/sys/arch/i386/compile/GENERIC.MP i386

gcc -O2      -I/usr/X11R6/include     -DCSRG_BASED  -DFUNCPROTO=15 -DNARROWPROTO       -c debug.c
In file included from debug.c:18:
/usr/include/varargs.h:43:2: #error "GCC 3.3 and newer no longer implements <varargs.h>."
/usr/include/varargs.h:44:2: #error "Revise your code to use <stdarg.h>."
debug.c:30: error: parse error before "va_dcl"

clean install + pkgsrc.tar.gz dated 20040117
cd /usr/pkgsrc/audio/xcdplayer; make