Subject: pkg/23975: ...pkgsrc/print/teTeX(2?) package conflicts with "omega".
To: None <>
From: Richard Rauch <>
List: netbsd-bugs
Date: 01/04/2004 07:08:18
>Number:         23975
>Category:       pkg
>Synopsis:       ...pkgsrc/print/teTeX(2?) package conflicts with "omega".
>Confidential:   no
>Severity:       non-critical
>Priority:       low
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Sun Jan 04 13:09:00 UTC 2004
>Originator:     Richard Rauch
>Release:        NetBSD 1.6ZG
  "I probably don't know what I'm talking about."
System: NetBSD socrates 1.6ZG NetBSD 1.6ZG (socrates) #1: Wed Dec 31 15:24:34 CST 2003 root@socrates:/usr/netbsd/current/src/sys/arch/amd64/compile/obj.amd64/socrates amd64
Architecture: x86_64
Machine: amd64
	I had the game "omega" installed previously.  I was rebuilding
	teTeX, and it refused to install because of a coflict with "omega".
	(teTeX has an "omega" program; the "omega" package is in games.)

	This is an old problem, but when you install omega, you are told that
	the binary is renamed to "Omega" to avoid conflicts with TeX.

	I believe that this conflict should be removed.
	Build/install the "omega" game, and then attempt to install teTeX.
	Remove the conflict.  (^&  (teTeX-bin/Makefile)  No patch provided;
	I think that it will be easier to do the edit than apply a patch.

	Workaround: Install teTeX first.  omega has removed the conflict
	from its pkgsrc Makefile.